(Bug on Thunkable Live X on iOS) Block "in list get #" returns an incorrect index in a large project

Can anyone check this information.

When you run in Thunkable Live X (last ver. 44) the project Thunkable on iOS, the Spinner displays the “item 2” and in text line Label (as shown)


Did you solve this problem?

This problem is still not solved. Try using the “in list get sub-list from # to #” block instead of the “in list get #” block.

Thx @actech I am having the same trouble. Yesterday I made a post in your thread on github. I will try the get sublist component as a workaround

I was having trouble with indexing earlier today, but was able to fix it. The list viewer seems to be indexed starting at 1, but other lists are indexed starting at 0, or theres a bug in how it returns the index. subtracting one from the list viewer index worked for me

Due to problems with lists, I start thinking about using blocks for working with text instead of them - converting the list into delimited text and manually searching for the necessary element by it.

Today I updated Thunkable Live and saw that my big project, which at start-up consistently produced the wrong index of the list, now works well.

If you have a huge project gives an incorrect index of the list, then update Thunkable Live, make some changes on the properties panel of this project and only after that start the project for testing.

Many errors occur due to the unsynchronization of the local project and the remote one, which is used to run in Thunkable Live. For example, you changed the blocks, but these changes did not go through and Thunkable Live displays the old version of the project for the reason that it seems that the project has stopped working. How to check whether the project was updated remotely or not? To do this, after changing the blocks, you need to change some property in the properties panel. For example, I add a number to some Label text.

This project update should be done after the update of Thunkable Live. Do not expect that everything will update itself.

thx for your information @actech,

but my experience is totally different:

1.) I cannot see any update of thunkable live (neither in the appstore, nor in playstore)

2.) My big project still has the “get…in list” bug. It also would be strange if one of the @thunkable developers would have found the root of the problem after months and tell nobody about it.

3.) the thunkable live version is always 1 step behind, when any change was made in the block-section. Changes in the design-section trigger a new compilation but do not trigger a new compilation of the block-section.

4.) Big projects seem to have even more trouble when using tab navigator. I hope this is recognized by the @thunkable team.

Are you using version 48 of Thunkable Live?

Instead of “get #” try using “get sub-list”.

There are problems in huge Thunkable projects - I agree with that.

I checked the list for iOS 10.3 and see a problem with “in list get #”. It turns out that, on my iOS 11.4, the error in indexing the list was gone, but on iOS 10.3 it remained!

ah, now I understand what you mean with “update” . I am using a iphone 5 SE, iOS 12.0.1 - and having trouble all the time :wink:

I disagree with that. I do not think Java and Swift bring the maximum stability and reliability. I think a specialized group (thunkable developers) can take care of these and thereby make it possible for a large group (community and paying customers) to create awesome apps like your app, which definitely is.

I might be corrected, but I think the recent updates were a little bit too progressive. I like progressive behavior for new components. The basic components and blocks (text, variables, lists, objects, control, Button, Label, Row, Textbox…) should be handled with care

When using Java and Swift, the developer gets the implementation bugs for Java and Swift. Thunkable also uses Blockly, ReactNative and other technologies. So, in addition to the bugs and errors of Java and Swift, bugs and errors are added to this whole technology pie. Do you agree with this?

The developers of Thunkable X took on the extremely difficult task of making equally good functionality for both iOS and Android. Apple’s policy will not make good functionality for iOS, so I see two options:

  1. Make iOS and Android functionality the same, sacrificing Android functionality.

  2. Make the functionality different for iOS and Android. At the same time, under Android it will turn out to make the functionality significantly higher. But this will lead to confusion, as it will be necessary to separately indicate that it does not work under iOS.

The first option remains, but I’m afraid that the Thunkable X for Android functionality will be noticeably lower than the Thunkable Classic for Android functionality.

Have you tried using the “in list get sub-list from # to #” block instead of “in list get #”?

:frowning: sub-list is still a list and if I want to get an entry I have to take the corrupted get…in-list block

I use your advice in combination with this:

Does this fix the indexing error on your device? If there is no error, then we are a workaround. I do not like such crutches, but without it is impossible to take new steps in the development.

yes, because it does not use the corrupted get…in-list component. Unfortunely it’s useless because there are three more bugs related to realtimeDB and functions and variables and tab navigator… :sleepy:

too many bugs :space_invader::space_invader::space_invader::space_invader::space_invader::space_invader:

:slight_smile: Instead of Tab Naviigator, I made my Button tab navigator, but this is a bit of work.

I will look again at your message regarding the remaining errors.


Today I updated my phone to iOS version 12.0.1 and was surprised to see that the bug with the first launch of Alert in a huge project has disappeared. Old bugs disappeared, and new ones appeared. It does not let us be bored! :sunglasses:

In my project the bug is still present and making it impossible to use thunkable.