Background image won't fill the screen

Hi. I am not sure my messages get through, I have tried to post in another thread but I get no replays and I am start to thinking it may got something to do with the status for that conversation/thread?? It says it’s “SOLVED”. But I have further questions there, so I thought I might post my question as a new topic, and if this status “SOLVED” has nothing to do with my missing responses, and people indeed see my posts in the original conversations, then please feel free to delete this post if you need to.

Original conversation:

My issue:
I have now updated to latest version of IOS. This is my result when trying to set a background image to fill my screen:

None one 3 different ways I am using is working for my iPhone XR.

Can someone please help me if I am doing anything wrong, or I really wish you guys at Thunkable could rise this as high priority if it’s a bug?



Usually, we ask people not to create a new topic for an issue they’ve already posted about. But for some reason, the original topic is not accessible so it’s good you posted this.

Screenshots of your previewed project are helpful but they are the least helpful detail you can provide.

What properties are you setting for your background image’s height, width, background resize mode, etc.? Is the image in a screen or a row/column/group?


Thanks for your reply.
Oh, sorry… I will try to be more detailed and specific.

So, I have an image that is 1396 × 2424 pixels which I use as an background image for my Screen, so I have put it as a background directly in my Screen, no rows or columns…
I use Cover mode, I have also tried Stretch and contain, but none of these will fill my screen after download the app to my phone. It looks ok in the simulator but as soon as I download it it will display like this.

Here are a screenshot for the settings and modes that I use.

What do you mean by properties for height width?

Thanks for any help! :pray:


Sorry, those are only going to appear if you are using an Image component. For a screen, you won’t have those.

1 Like

So is the problem that the top “notch” area doesn’t show your background picture? Or that the bottom doesn’t? Or both?

1 Like

Both :blush:

As I described in the first post,

When use the “ignore notch area” - it will not show my backgroundimage on either top or bottom.

When use a colour for that area - it shows that colour on top only, not bottom, AND the top gets a white stripe in it… as if the colour missed a piece… or the notch area was not heigh enough.

When use transparent for that area the backgroundimage won’t show fore either top or bottom.

1 Like

Another user has reported this issue, too:

You may want to submit a bug report on GitHub:

1 Like

Thanks! I have reported this as a bug now. Thanks for your feedback!
If you would come up with any workaround in meantime that would be much appreciated :slightly_smiling_face: