App rejected from App Store due to a button with "open link" block

Hi everybody,

App Store finds a bug with a button with an open link block and it won’t allow my app into the App Store: Apparently the button doesn’t lead to anything.
It’s actually just one block with a link.
I have downloaded the app and it works perfectly. The link does exist and it works.
It actually opens a browser page. I have also tried to do with a WebViewer, and it works either, but still App Connect won’t let me through.

Are they any known issues with this block in iOS?
Thank you

Hi @maurizio.polverini89 - can you copy/paste the exact text of the email that you got from Apple?


We still discover one or more bugs in your app.

Specifically, when we tapped on Storia, a blank white page presented and still no content displayed.

Review device details:

  • Device type: iPad
  • OS version: iOS 14.2

Next Steps

Please run your app on a device to reproduce the issues, then revise and submit your app for review.

If at first you’re unable to reproduce the issue, try the following:

  • For new apps, uninstall all previous versions of your app from a device, then install and follow the steps to reproduce.
  • For app updates, install the new version as an update to the previous version, then follow the steps to reproduce.

If we misunderstood the intended behavior of your app, please reply to this message in Resolution Center to provide information on how these features were intended to work.

Please see attached screenshot for details.

And have you been able to test this for yourself on an iPad @maurizio.polverini89?

Also, what link are you trying to open?

I haven’t tried it on an iPad as I dont have one, but it works good on every device from Thunkable’s WebApp Developer mode.

The links are some cocktail’s histories, literally it’s just a block-link to famous websites where the cocktail’s story is shown.

1 Like

Ah yes - I know your app now. :beers:

This is a good idea @maurizio.polverini89 , but not the same thing. Can you share your project link with us (either by PM or by email) and we can take a closer look at it for you.


1 Like

I sent you a pm!

Still no luck with this.
Apple must hate me.

Hey Maurizio,

how do you get to the developer mode?

Do you still have this issue or if not please share how it was resolved?