Admob does not appear after publishing on Google Play. HELP

in my project admob ads work perfectly. but when i download the app nothing happens. the app has been published for a few years, this happened now in the last app update and I didn’t change the ad units, I just added some labels. thanks

Hey Fernando

In the title you make reference to Publishing your app, but in the question itself you say you’re only downloading:

Do you mean “when I download and publish the app nothing happens”?


Also, you generally don’t want to be using the production version of you app to avoid getting hit with “invalid traffic” reports from Google. Have you set up your account to ignore your personal device?


What’s it saying in your AdMob dashboard? Is there perhaps some recent update to terms and conditions that you need to accept first?

1 Like

@domhnallohanlon yes when i download through google play. the admob shows thousands of ad requests and 0 impressions. I’ve also asked some friends to download the app and no ads appear on their devices. and I don’t have any new terms to accept. thanks

Are there any messages in your AdMob console?

Usually you’d expect to see something in your notifications around this.

Are you a member of our AdMob MCM?

1 Like

@domhnallohanlon there is no message in the admob console. and yes I am an MCM member I have the Pro plan

hello i submitted an admob review with a new account. is it possible for you to take a look and accept?

Hi @domhnallohanlon I tested another app and the ads work. so it doesn’t work in this app after creating the apk and aab.

Hey Fernando,

Can you send me the projectURL via DM? I’ll check out your projects AdMob access on my side of things. I did admob reviews yesterday. Perhaps you submitted after I looked over things? I’ll check it out again today and push yours along regardless! :slight_smile:

[Update] I have worked through all our admob requests. Everything is up to date. You should have received either an acceptance or rejection email. Please let me know if you got that.

Hi @jaredgibb1 i found the problem. when I change the name of the app bundle id the ads work 100% but when I have the name of the original app bundle nothing works. How can I solve this problem?

1 Like

Let me try to help you out here! :slight_smile:

Have they ever worked in your app or was this the first time you tried adding them?

Do you need to use some specific bundleID in order to use the ads or can it be any random bundleID?

@jared this app has been running for over 2 years with ads. but now it has stopped. the app has to keep the same app bundle ID to be able to push the update to Google Play

So, from the outside looking in, it would seem as if the bundleID has been blocked from serving ads? While we try to sort things out, can you start a thread with admob support about this issue and share with them your bundle ID and Admob ID. Can you also check here Admob Policy Center for any issues?

2 Likes