Why aren't my sprites appearing on the canvas when I test my app?

Hello Thunkable Support!

I worked on my App "White Wolf " for a while now, and now I have the problem that the sprites on my Canvas don’t show anymore. I exported the app as an apk and installed it, but it doesn’t work. But on the live test feature it does work well.

I would be really happy if you could help me solve this issiue!

Timo

2 Likes

Welcome to Thunkable.

You have not provided enough information for anyone to help you.

Is this problem specific to this project only?
What if you start a new project and add a canvas and a sprite and try it in the mobile Thunkable app, will it show the sprite or not?

I work on this project for about a month now, and I always made copies to have a backup.
This is not the first App I made, so I have a bit of experience.
On the last backup of my Game wos this not the case!

2 Likes

This is nice to know. Can you create a new project and reproduce the same condition and share the project so others can have a look?

The project with the problem in it, took me quiet long to build, so is it okay if a share a copy of the Project?
Link to the copy:My Sprites doesn't show on the test app or the installed version but on the Web Preview!

1 Like

You are linking the same POST.

Oh Sorry!
Here is the real link: Thunkable

1 Like

I noticed you have invalid sprites under sprite1 images. Remove the invalid ones and it should work OK

image

And do the same for all other sprite types.

1 Like

Oh my god!
It works!
Thank you for your help!

2 Likes

You’re welcome.