Vibrate block in Device component doesn't work

Hello friends.

Please I need help. I’ve been trying to make a robot app I built for iOS vibrate when a button is clicked, so I added a vibrate block. when I click the button, nothing happens.

Please find attached a copy of the block

Any help would be much appreciated. I’m testing my app on an iPhone 6S running iOS version 11.4.1

Thank you

Hi, @kufirre! :wave:

Welcome to the Community! :blush: :tada:

It might be that, the Bluetooth_Low_Energy1 call Transmit is not Transmitting.

To catch the error, try these blocks -


Note: Please use the else if instead of else in the if block.
There’s a little problem with else going on, hope the dev. s are looking over it.

Hope I helped you! :smile:

Thanks! :blush:

1 Like

Hi @kartik14

Thanks a lot for your response.

I’m going to try this as soon as I get back on my computer

Thanks again:slightly_smiling_face:

1 Like

Hi @kartik14

It’s transmitting OK.

So, I tried to move the vibrate block from where I placed it to the bottom of the “when-do” block and it now works just fine.

Thanks a lot for your help though, you’re too kind.

***Please find attached an image of what I did that worked for me (I don’t know why that should be the problem though


Hi, @kufirre! :wave:

Glad to know, that the problem is solved :blush:
So, if I helped you, please mark my above post as Solution :white_check_mark: , then it will clear this topic from the unsolved problems, moving it to solved problems :wink:

Thanks! :blush:

okok. thanks

1 Like