To Do List Deleting Wrong Item - SOLVED

Good morning,

I searched for a possible solution regarding my problem but couldn’t find anything so please accpet my apology in advance if I missed it. I recently created a simple ‘to do’ app that allows me to add items to a list. One of the features of the app is the ability to delete an item, any item at any time using the alert component. The app worked great until today (at least that’s when I noticed it not working correctly). The app still lets me add items, however, when I tap an item I want to delete, instead of it deleting that item, it deletes the first item in the list. I’m using a cloud variable to store my list. Attached is a screen capture of the app, with the “list to do” nest being the problem code. Thanks so much in advance for any help provided!

Hey @Scott_Turcotte, I see you’ve added “solved” to your topic title.

Would you mind sharing with the rest of the community what the solution was, so the next person can have the benefit of your experience too?


1 Like

Sorry I forgot to mention the fix. For those interested I just swapped out the “item” block with the “index” block for that nesting of code. For some reason I thought that I had it working with the “item” block so I’m not completely sure what happened, however, replacing it with “index” did the trick!

1 Like