Thunkable doesn't display my text input

Hi there, because my list is very long I created a text input so it would be faster to get the item. However Thunkable doesn’t display it on the screen. The list viewer drops down when the text input should appear. Does anyone know what could cause that? I haven’t linked my text input at anything yet so it can’t be the code.


@jens12341234 - it’s possible this is just on Thunkable Live.

did you try installing your app to see if the same thing happened there too?

No I didn’t Can you download your app on an IOS device? I didn’t know that. I’ll check on it.

You certainly can! The whole reason Thunkable exists is to create cross-platform apps.

Here’s a guide from our docs:

I installed it and it was exactly the same, what do you think I could do? Do you think it would help if I completely delete the row of the text input and put a new one in? In some cases it helps but not always.

There seems to be a lot of spacing between the label that says “Please select a city” and where the list viewer begins.

Check out the translator app at the bottom of this tutorial, it seems to be very similar to what you want to do:

The search result is an empty list, all the time. I noticed that if I open it on Thunkable live or in the real app, the text input doesn’t show up but if I use the online Thunkable on my computer it does.

As @martint said in this post (I faced the issue too, and made another topic because I can’t find the solution in your discussion), go to your advanced settings of your text input and change the editable option to false and then true again. It worked for me really well!

Dear @anikathescientist
I know you are excited to have solved your issue but it will not make any benefit to REPOST in a thread with the last change was 2 years ago.

1 Like