There is an App Variable listed that I cannot find the Initialization for

I have tried searching for the answer, but the keywords I am using do not bring up my issue…however I am new to Thunkable, so I might just not being using the right ones.

In my list of App Variables that I can select “Scenario” which tells me the App itself is initializing it. However, for a while in the dropdown list of selectable App Variables there was a duplication of that name. I have since deleted the only “Initialize app variable command I had” but the “Scenario” option is still there.

It is like there is a hidden visualization somewhere that I cannot find. I want to find it and clearly place it in the appropriate page…or completely delete that app variable and start over. Thoughts?


image

If you delete a variable Initialize block, it should delete the variable from the list of variables.

Have you tried a hard refresh of the browser tab? Or clearing the browser cache?

·····················································································································
Need help? How to Ask Great Questions :sparkles: Debugging A Project :sparkles: API JSON Tutorial

Want to hire a Certified Thunkable Expert? Elevate your app with Tatiang on Fiverr

1 Like

I tried the refresh, clearing the cash, and even installing a different browser (was on Chrome, trying Firefox)…I have also deleted all references to the variable…No change.

It is still hanging around in the Variable list.

image

Two more things to try:

  1. Right-click on every screen in the project and choose “Clean up blocks.” Note that that will re-arrange your code blocks and cannot be undone. See if that helps you find the missing Initialize block.

  2. Check loop blocks and function blocks – if you have any – to see if you created the variable there. For example, if you have a loop that says for every j in list… and you rename j to Scenario, then that becomes an app variable as well.

If you still can’t find it and want to share the project link with me, I can take a look too. Or you can send it to Thunkable Support if you have a license that allows that.

I tried the first suggestion, but I am not sure what you mean by the second.

I have replaced all references to that variable that I can find, it is not initialized in any screen, but it remains.

Hello @jns.paramedic
A workaround to solve this issue is to duplicate the screen where you first set the variable, and then delete the original screen.