The map component stopped working

the map component stopped working
from one day to the next it stopped working

1 Like

Thanks for letting us know.

1 Like

Hey, @Dean_Artis and @Vaiper_watafai:wave::wave:
Can you share a screenshot of your blocks?
Because for me, it is working. :face_with_raised_eyebrow: :face_with_raised_eyebrow:

It was working and now it stopped
here I leave you some captures

In the app it does not show the map, this error had already passed me the solution was to redo the application, xq if I place a new map it does not work either, it only works by doing the app again

Have you entered your specific API key or are you still using the map without a key?

I use the keyless map
I already solved my problem, but this is the second time it happens to me
I don’t know why the map stops working after a while, it shows nothing, remains blank

1 Like

ok use some api keyys if u wan help i can

I’m going to use some api keys to see, anyway I already solved it by doing it again

@Vaiper_watafai ,

I just ran into a similar problem and I think I have a solution. I think it may be a Thunkable Height issue, rather than a problem with the Google API. I created an app to illustrate the problem.

On the screen there are 3 columns, each with a map inside. The first column is set to height Fit Contents, the second is fill container, and the third is an absolute height.

When I view the app on my android device, the first column (fit contents) is completely collapsed (blue border). The other 2 columns are sized properly and show the associated maps.

I see in your app you have 2 columns. To debug the map issue, try setting those columns to an absolute height of something very small, like 1 or 10. Does the map then show up? If so, it may be an issue with the column sizing like I had.

Happy Thunking!