[Solved] Webviewer not responsive / scrolling issue

Hi there,

Today I ran into a problem with the webviewer and I searched the community but all the similar issues I found should already have been fixed or do not really match my case.

I embedded a local .html file in the webviewer and in the companion app I can barely scroll it and it has a weird scroll issue like shown below:

In the built app I cannot scroll at all. The webviewer is set to scrollable, the screen is not because when it is the webviewer disappears. There is no other component on the screen and I also tried to separate it from the top navigator for testing but it stays the same…

The html file is pretty basic and has viewport settings for mobile view as follows:

 <meta name="viewport" content="width=device-width, initial-scale=1.0">

I have a webviewer with online content in the same app and that works fine so I can’t find the issue :frowning:

what happens when you turn bounces off?

I tried that and it did not scroll at all in the companion when turned off.


Can you share an MWE so we can take a closer look?

Aww I’m sorry I think I finally found the problem. The CSS framework I used had the body positioned as ‘fixed’ and this seemed to make the webviewer stumble… I know it is strange why one would put the body position of a webpage to fixed anyway but I guess the reason in this framework was to get rid of the scroll bars to make it look more native. Might need some js to work with that but for now I just got rid of that faulty css part.

Thank you anyways for your help!

1 Like