[Solved] Permission Denied when trying to access Photo Library

The “photo library - select picture” feature is not working on my APK, after downloading and installing in my android terminal.

After selecting the picture the image goes blank.

It works perfectly in the android emulator but not in the downloaded APK.

Try to display the values of all the blocks that work with data after selecting a photo. You need to clearly identify the block that doesn’t work.

Ok I displayed the error on to a label after selecting the picture and it says: /storage/emulated/0/photos…/… opend failed: “EACESS (Permission denied)”

I checked the app’s permissions in my phone setting and both camera and storage are allowed.

Now you know how to search for errors.

I do not know how to fix this error. This is a question for developers Thunkable X.

Since August 31st, the camera and photo library component stopped working on my Android, both in apk and in Thunkable live. :sleepy:

Here is a screenshot of the issue I have.


Same issue here

Hi there,

Any news on this? When the fix for this is supposed to be released?

Please let us know. Thank you!

somebody please help. same issue here and still waiting.

Hi there,

We published a fix for this behavior today. Can you please try downloading your app again and test it out?

@Javier_Aquique @f7a4d55febb042 @Tommaso @saramdl.gaunde021

We recommend filing bug reports in our public GitHub repository to ensure that they are seen by the team. You can find instructions for how to do this in the pinned post of this forum.


The fix worked like a charm. Downloaded the APK again, installed it and watched it work.


please help me ,I can’t use camera or photo library .I just want a button to upload image file to show . trying to do this million times ,still not working.

1 Like

Please stop spamming the community.

1 Like

very sorry.

1 Like