[Solved] Is there any issue around adding Invisible Components?

The problem is yesterday.

1 Like

Same issue here. Whenever I try to add an invisible component - e.g. Airtable - the browser refreshes and is showing me a completely empty page afterwards. The component is not added.

For existing project, the same seems to happen when I select that component.

This happens for me with Safari, Chrome and Firefox.

1 Like

Hey @Balanced_Kitchen and @docbobo :wave:

I can’t seem to reproduce this behaviour in Chrome:

We did a platform update yesterday, can you try doing a hard refresh in your browser and let me know whether or not that works for you.


1 Like

this is after hard refresh

I am a high school teacher and have about 20 students with the problem described above. We have tried the Ctrl-F5 reset. We have also signed them in using alternative accounts. We are using Chrome 79.0.3945.130 but I just upgraded to the latest 80… and have the same problem – even after hard reset. One student also tried Edge – same problem. I have a total of 165 students, and we didn’t have this problem yesterday. Componenets added yesterday are still there and working – so it’s something with the process of adding. We have tried the location sensor, realtime db, and several others.
Any other ideas?

1 Like

Hey @Lee_Nicholson,

Really sorry for the inconvenience with this.
Can you do a test in an incognito window and see if this issue persists?

1 Like

I am also encountering this issue.

I hope the staff is looking on it :blush:

@domhnallohanlon I am using Google Chrome 79.0.3945.130 (Official Build) with Windows 10.

Thanks! :blush:


the problem is also available in incognito window

1 Like

OK. Same here. Incognito doesn’t remove the problem.


We tried this on a Mac Airbook with Chrome and have the same issue as Windows 10.

yes. i noticed… :angry:

then i figured out my issues :wink:

What was you issue @jared?

@domhnallohanlon, thanks for checking in. I think it was syntax.

so first, i used to do what was circled in red, but i think it was incorrect syntax and i changed it to whats circled in green.

I was checking a list for a ‘#’ when i should’ve been checking a string for an instance of ‘#’ since my function returns a single value and not a list. strangely though, i’ve been using it for months that way.


Here, I was doing the same thing, checking in a list that didn’t exist instead of a string

Also, it seems like one of my variables doesnt always initialize correctly. I’m not sure. I just got this save button to work again. I downloaded and am doing testing. I will report.back. All i did was log out and log back in. :cry:

I don’t think that’s related to this - thanks for the update though!

1 Like

@Lee_Nicholson @Balanced_Kitchen @kartik14 @docbobo

Thanks for flagging this with us. We’ve been able to reproduce this issue on our end and so far can confirm that it’s limited to invisible components.

The dev team are looking into this right now and weshould have a hotfix out as soon as possible (i.e. today!)

We’ll update this thread as and when we have more information to hand. If you see any new questions related to this in the community please direct them to this topic

For the time being, the crash is only caused by clicking on an invisible component. You can still add invisible components and work with the blocks of these components. Refreshing your browser will restore your current session, so the advice for the time being is just to not click on an invisible component in the designer.

Thanks again for flagging this with us everyone!

1 Like

Thank you for the attention to this. When you mentioned clicking, I was puzzled because we weren’t actually “clicking”. We were dragging/drop the component onto the screen image in the center of the IDE and it was (and still is) happening. On the other hand, when you drag the exact same component into the “Invisible Components” section of the left panel, it pops in perfectly and also shows in the center as one would like it to. Then, when/if you click on either the left panel icon or the center screen icon (as you told us not to), the white screen pops up. I’m just passing this along in hopes that the different response to the two methods of adding a component might provide some insight for the problem-solvers.

1 Like

Thanks for your patience with this - a fix has been deployed and the issue has now been resolved.

You may need to do a hard refresh for the changes to take effect in your browser

Just to summarise this:

12:54 - Initial post about this in the community
13:32 - Issue opened on Github
13:59 - First response from Thunkable Staff
14:44 - Further reports of crashes
15:01 - Issue reproduced by Thunkable Community Team
15:46 - Issue escalated to the Dev team
16:36 - Fix is pushed
16:55 - New build deployed
17:19 - Fix goes live. Issue is resolved

Time to resolution: 4 hours 25 mins.

CC: @Lee_Nicholson @Balanced_Kitchen @kartik14 @docbobo @Rob_Schoemaker


Everything is good now. Thanks!

1 Like


1 Like