[Solved] get object from json

So… i have an app that ive been using vpic to get information from for months now…


all of a sudden thunkable is unable to “get object from json”

Here’s an example of the json… its flat and its absolutely not my setup, which has been the same, unchanged. it must have happened sometime last week, but it cannot read this json for whatever reason. can someone else try and do this to see if its just me?


I simplified is as much as possible, nothing!!! it just refuses to do it.

the plot thickens, because it does it in the web version just fine…

Its 10:46 PM where i am, its time for bed… if anyone would be so kind as to try this and see if they get the same result i would be unbelievably grateful

1 Like

Update, i was too neurotic to just go to bed… I had to uninstall and then reinstall the app to fix this.

However, I do think the staff should absolutely see this.

1 Like

So are you saying that reinstalling Thunkable Live fixed this? Or that reinstalling the downloaded project on your phone fixed it?

1 Like

Just acknowledging this I’ve seen your post!

Glad to hear that you got this working @bluerfox15uht9 do you know what version of the Live app you were using? (The current version is v265 and v266 will be out later this week)

Was there any change to the URL in your app? Were you looking at a cached version?

Was there any error message or error in the console that I can check for you?


1 Like

I take it back, it seems like it still isn’t working properly and I cannot say why.

When an account is created, it automatically creates a database entry with a set of default information.

But it’s not popping any error codes

Reinstalling thunkable live fixed it.

it just keep crashing to the re-launch screen or the “reload” screen, do you want a link to the project?

I got the one json thing working, but it looks like it’s not wanting to grab the number of engine cylinders from the json, and its messing up firebase somehow

EDIT: I’m not even going to question why, but changing the name of the stored variable fixed it. Not sure if that small piece of information is useful for the staff, but still. . .