[Solved] Data viewer grid not showing up

Hello everyone,
It’s been a while since I have been active, so I hope everyone is doing well. I have had an issue similar to this in the past, but my old methods of fixing it didn’t work.

Issue Summary:
In my main App, I am having Data Viewer Grids not populate. Same issue with Data Viewer Lists. I was at first using a Table that was actively pulling from Firebase at page open. This stopped working, but now even hardcoded values aren’t working. See testing devices below, but so far I am only seeing this issue on iOS methods. The odd part is on the screen before, I have a working DGV. At first, I had some refreshing in the code and some other animations, but I removed those and just have it set to loading, and still no luck.

Testing Systems

  1. iOS Native
  2. iOS Thunkable Live (V. 296-4 and earlier)
  3. Live Test Web Preview
  4. Responsive Web Preview

Methods of Troubleshooting
Added a new viewer on the page.
Uninstalled and reinstalled Thunkable live.
Made a new test app with the same data table as what I am trying to copy, and it worked in the test app, but still not in the main app.

Screenshots
Thunkable Live web test (Working)

iOS Native (Issue)

iOS Thunkable Live (Issue)

Test App (Working) Thunkable live

Screen recording in TL

Does anyone have any thoughts? This is supposed to be an inventory app for my work, and it is currently not working, so my boss is warning me about wasting funding. This was working for a while, but then it stopped. I don’t have a great timeframe for when it stopped working.

1 Like

Without seeing the project or the way you have things set up, it’s impossible to know what might be causing the problem.

The only thing that comes to mind for me is… have you synced the data source recently in the My Data Sources tab at Thunkable?

Are you able to use blocks to get cell data from the data source that isn’t displaying properly?

1 Like

I’m assuming that you are using a Local Table in your app and when opening the screen first clear all contents of the Local table then loop through your Firebase data to load it in the local table.

If this is the case, I would do the following to test:

  • create a new Local table and populate it with data (Do not use existing table).
  • bind the new table to the Data Viewer Grid.
  • Run your app to see the output.

If this made the DVG show up then you at least localized the problem with either your existing Local Table or with your procedure of polling data from Firebase or it could be you are nor authorized to access the data in Firebase.

2 Likes

@tatiang I started with a firebase pull, but the first thing I did to test was switched to a pre-populated local table to test my link, and still no luck. But on that note, I know my pull is fine because it is working on a previous screen. See the below pictures. The load is working correctly for my home options (First two pics).

@muneer
Thank you for that testing idea. I was still unsuccessful even with the new table. So I have created a new table and new DGV, yet still no luck. Below are some code snippets and my tables.

This is for my first screen with a DGV, and this is pulling from Firebase, and working correctly. (First screen after the loading in the video from my first post)
HomeLoadCode

This is the table and commented out code for the screen that isn’t working. This is meant to pull from Firebase (Uses the same framework as my home screen) but doesn’t even work when I popular the local table manually. (This page used to look just like my first page, what is showing now is my testing. The table was blank and the code was pulling from Firebase)


Just to make sure, I tried two more tests. I removed all instances of code that altered the visibility of the DGV, and set it to visible. No luck. Next, I set visibility to false, added a .3 second wait on the open screen, and then set it to visible, still no luck.

To get everyone on the same page, as I know this message is a little everywhere, here is what I have at the moment. (Also, please let me know what is more helpful for you guys regarding my posts. I try to be detailed, but let me know if I am adding too many unhelpful details or not enough useful stuff) Both my new viewer and my old viewer are set to visible being true. The old viewer(List) references the old table, new viewer (Grid) references the new table with the same data.


1 Like

If that wasn’t enough info, here is a copy of the current project. Sorry, the code is a bit of a mess… I was working on other stuff before this happened, and I had to stop the new work and fix this first. The page in question is Inventory. Home page is what is working.

https://x.thunkable.com/copy/704ddd1483f2f7a124eec58ba1bfbf6e

1 Like

I copied your project and Previewed the Inventory screen.
I can see this

Yes, it works in the preview and preview as a web app, but not on iOS. You can see what I was seeing under the Screenshots part of my original post.

1 Like

OK, will check it tomorrow morning with an iPhone and update you.

@bnice
I tried running your app from my side but your app is fully dependent on the Firebase settings of your data set.

Can you export your data set as JSON and sent it to me so I can load it in my Firebase and run a proper test?

1 Like

Hello @bnice
The issue I found was too remote to the behavior but I’m posting it here because it fixed the problem. The main column was the issue, named grpVert. I took other components out of it and it worked

1 Like

Thank you for that info! I think I did find the issue, and it was my Home button. I changed it to absolute size, and everything is now visible. Thanks again!

2 Likes