[SOLVED 1/26/24 9:12 AM EDT] Easy API call with Airtable - getting "null" as value

Hello guys, i’m experimenting a bit more of API calls lately.
I’m struggling with some very easy blocks but i can’t wrap my head around it.

Screenshot 2024-01-26 135316

This is what i get:

I don’t understand why i can’t retrieve the “id” value and it shows me “null”.
My intention was to get the value “Ciao”, but i’m still struggling with the step before.

I know there are many API experts here, hopefully that’s an easy-to-solve one

Thank you for your time

Because the value for the property that you extract “records” is a list and not an object

You need to get item 1 from records array then grab items id


I tried to get the list, i had this feeling, but apparently i did it wrong the first time.

Thank you @jared now it works

I leave here my blocks in case someone else will need it in the future

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.