[Resolved] Issues while using Toggle Drawer Menu block

Hi Thunkers!

I didn’t make any change on my project home screen, but since this morning the ToggleDrawerMenu is showing an error at runtime.

Below the block I use to call it:

And this the error when I click the button to show the menu of the APP:

I have no idea whats is causing the strange error. An old version of the app (I have a copy with the same contents in the Home Screen, but there works perfectly).

Any help will be appreciated!

Regards!

1 Like

Would this be related to your issue (see the last comment)

1 Like

can you share the project with me @paulovaz72

We made some updates very early today. I’m wondering if this is affecting you and if so we need to get it sorted out asap!

Best,

2 Likes

Sure, I will do in private.

Hi @jaredgibb1_2_3 I sent you the project link but the problem stills happening.

In fact I see when I change the ToggleDrawerMenu proprieties in any screen attached to the menu, they stops to work.

Any news on this? I’m running out of time to finish and start tests in production of my project and this problem is putting my final delivery in risk.

Sorry to push you, but I really need to solve this! Anyway if there is some workaround I can do it!

Regards,

Paulo Vaz

1 Like

can you confirm that you are in fact using a navigator in your project?

1 Like

Yes, I do. Did you check the project link I shared in private?

2 Likes

Me too. How to fix it?

hello everyone, does anyone have. can you help me? I use the Drawer Navigator component and use the function when the image is clicked the Drawer Nagivator will appear, but instead an error and this is the result of the screenshot from the error.

1 Like

See this post

No solution or workaround until now. Looks to be a bug not fixed yet.

I think @jaredgibb1_2_3 is working on this with the staff.

I also found some issues in the Map component that I will investigate better, but I see another post about these issues too.

This problems starts from last week after an update in Thubkable :frowning:

Hope the team fix these issues soon!

3 Likes

Hello, I’m having trouble with the TogleDrawerMenu. Now every time I update a screen, if I try to open the menu the app crashes. did it happen to you? solutions? on the other hand, everything works fine in the other screens. Thanks

1 Like

According @jaredgibb1_2_3 next week we will have good news on this issue.

Hope to also have solution for the maps issue too…

Hello Thunkers !
Trying to modify an old app of mine, that is published and works just fine, I just encountered this problem:
A) working blocks:


and the result of activating it:

B) wanted to eliminate some language, so I did:


And without any other modification in my blocks, trying to activate DrawerNavigation now has this result:

Seeing this, I tried to LiveView my old app source (published on GoogleStore and working just fine) and i had the unpleasant surprise to get same error, even without any modification for the initial DrawerNavigator blocks.

Something bugged ?

PS. Later edit after further investigation: … In fact the error is on call block. Drawer works if I use swipe gesture to activate it… I get that error if I try to activate it thru button command as in my block …
So this is broken:
002

1 Like

Yes, it’s a bug that was reported by me 2 weeks ago in this post. The team is working to solve it, so let’s wait, hope to hear news this week!

Any change done in a project that uses ToggleDrawerMenu or a new project, will give you this error…

2 Likes

If it is useful for the Team, from what I have seen, even simply by entering the blocks, without making any changes, from that mistake.

Thank you for your answer, letting me know that is not my mistake :relaxed:
So, with this, I just can’t publish anymore any updates, as will results in crashes… until its been fixed by @Thunkable_Staff

1 Like

The same situation I’m facing… that’s why is very important to fix this soon!

1 Like

I just came across this problem as well :frowning:

1 Like

Mismo problema, necesitamos una solución, por favor, saludos y gracias

1 Like