[Resolved] Issues while using “Create Component” block [April 2022]

Hi folks,
Sometime recently (within the last couple days), my apps that utilize the “Any Component” Create block have started crashing. The crash occurs specifically when that block runs. I noticed it because I tried to make a new app using this block, but apps created about a month ago are crashing when they hit the block as well (and they functioned at the time). Has something changed in the code base recently that would cause this?

Here’s a simple example: Thunkable

This adds data to a list, then tries to create a component for each item on Screen2. But it crashes for me when I go to Screen2 - both on the web preview mode and also on the Thunkable iOS app.

1 Like

There was a recent update that others has faced some issues and was fixed literally the same day as reposted by @jared

Have you tried it today?

Yea, I first noticed the issue yesterday, and I am still experiencing it currently.

1 Like

It’s crashing at “2” right before creating a label so yeah, looks like a new bug:

This also crashes Screen2:

image

These two blocks crash the first screen when it opens, both in Preview and Live Test:

image

Simplified example:

https://x.thunkable.com/copy/07a207e1eea97bbb3f76995e3c6b0e24

I’ve isolated the problem to the create label block. I removed the navigator from the project, deleted the second screen, and even tried a when button click event instead of when screen opens.

I would encourage you to submit a bug report if you haven’t already. You can reference this topic.

To check in here. Is it crashing when you create any kind of component or only when you create labels? Is there any chance that you could throw a minimal example up here so that I can share it with the team today? Otherwise, I can get to it tomorrow when I’m back at the office and will have to create the example myself. If you already have a working example with a few blocks I would be happy to take it and pair it down for tomorrow when I can upload it to the team bug reporting form.

The simplified example link I posted above is as minimal as it gets. I don’t have time to work on other examples right now. I was just trying to help out with this since I didn’t discover the bug. I might have time this evening to do more.

2 Likes

Sorry. I didn’t see your example!

That works for me thank you so much. It’s much appreciated

1 Like

I’m getting crashing with several components (labels, columns, rows).

I have also tried creating components inside on-screen containers (in a column) and on the screen itself.

I have tried creating components within a Screen.Open event, but also within other events (like a button click).

All of these are causing crashes.

Update
Just posted an issue on the GitHub repo.

Just to inform and to keep me updated… I’m experiencing this same issue.
In my case is a create loading icon and labels.

Hi jared! No fix yet, after a whole day?

I’ve submitted this as a bug report. We’ll address this first thing next week.

2 Likes

Still nothing here?

I’m facing the same issue. I have no problem with creating components (to be more exact, images/buttons) for Android nor for iOS live testing–but with iOS builds (if I download them), I face the issue, i.e. creating components crashes the app. Been struggling with this today. Please fix this soon… Thank you!

Ping @jared @jane etc.

1 Like

Weirdly, when I tried to build with a copy of my project from a week ago (with create component), the build worked (when downloaded for iOS). But the project I’ve been working since (without touching create components though), doesn’t work properly with them… Something’s off here.

1 Like

Hello all,

Hey all! I believe the issue has been identified and we will be testing a fix early next week. So sorry for the delays in getting this fixed! I will circle back as i find out more details.

Best,

2 Likes

Thank you! Would be great if this was fixed somewhat soon. I have an app update pending on App Store waiting for this to be fixed.

So, long story short and to recap, at least for me, create components work otherwise but not when I actually download an iOS build. So even for iOS live testing everything works fine, and naturally on Android too. Just to help you to focus on where the problem is now manifesting itself (at least for me).

1 Like

It works now! Great! Just received a message from @jaredgibb1 that it was fixed and I tried it, and it really works (for downloaded iOS builds). No more crashes. Nice. :slight_smile: I was also adviced to do a hard refresh inside the project, but forgot to do it, but it worked anyway. But good to keep this in mind.

1 Like