Problem with publishing app in app store with push notification

I have send mail to Thunkable but get no respons.
Don’t know how much I give for that PRO version :frowning:
So hope someone in here can help me.
I get this message


It looks like the Push notification is disable. But in apple store it looks like this

Where you under Enabled Capabilities can see that Push Notification is enabled.
Does anyone have a clue what to do. There also seems to be some simular problem on Google store with the push notification…


Hope someone can help me so I can get my app published…

There’s a step-by-step in this community post of what to do:

And there’s a section in the docs dedicated to adding push notifications too:
https://docs.thunkable.com/publish-to-app-store-ios#adding-push-notifications

2 Likes

Hi Domhnall O’ Hanlon,

I have been staring at that step by step post in the doc, and sorry to report, I do not get it. I think Apple changed their interface significantly after the post was done, so it does not comply anymore.

I do not see anything which remotely helps me so I hope you can :slight_smile:

I want to add push notifications, so what do I do with the Apple stuff…

My question is only as toward to solve the Apple provision problems related to this.

Henrik

Hi Domhnall O’ Hanlon,

I finally got it…it only took me a day :slight_smile:

You need to add Push Notification, attempt a publish, let it fail and then follow your guide…

Being a damm control freak, I tried to solve the problem before adding push notifications.

Perhaps a few other like me would appreciate that tip in your great guide?

Just my 5 cents.

Henrik

Hi @funhall,

I can’t help but notice that in your certificate under Type, you have it set to tvOS App Store. Have you tried changing this to regular App Store and followed the guide posted above.

Let us know how you get on!