Onesignal API only works in only 1 text block. "join" is not working

hey guys. i was looking forward to send push message by Onesignal API so hard.
And now i just succeed but it is kinda weird so i need your help.

this is my code

and if i run it then the result message is like this.

and i was thinking there were so many slash(/). so i just tried type in one block instead of ‘text join’ block.
and boom. it works.

but i don’t understand.
why text block include slash? i need ‘text join’ block.
Please help.

References]
API documents in One Signal : Create notification
former artical about this in the community : Sending Notification to Specific User with Onesignal

I don’t think this is related to the text block @saramdl.gaunde021 or the join block, you simply have a mistake in your JSON.

The error message says: unexpected character at line 1, column 10 which is the 10th character. If you count 10 letters in you have a = where you should have a :

Hope that helps.

1 Like

omg haha that was my mistake. but i still receive error message.

now i got
“Message Notifications must have Any/English language content”
despite the fact that i already have the content.

or other case of APIs (change user’s tag), if i do in the same way (which is not using join block) then i get right result. but if im do it with Join block, then the result is,

“There was a problem in the JSON you submitted.”,“unexpected end of JSON input”