Need help: Screen automatically crashes when launched. Even when I unplug the code behind

One of my screen won’t open. I just found out yesterday by one of my users, while working just fine a few days ago. I tried to remove all the code launched “when Screen opens”, but the screen is still crashing. Even in preview mode. Need help.
Basic components on this screen:

  • 1 data list viewer (linked to a local table for the data source)
  • 1 date input
  • Labels, buttons, image… nothing fancy
    No navigator
    All other screens work just fine.
    Does anybody have a clue? Thanks a lot for your help!
1 Like

This could be giving the effect
image

1 Like

It may, indeed. @Thunkable team any idea?

When you say crashing, what does that look like?

What platform does the app run on that it crashes. Does it crash on all devices.

Can you reproduce this issue or is it relegated to that single project and screen?

Hi Jared,
Thanks for your reply. When I say “crash”, I mean the screen doesn’t even start.
In the preview mode the phone doesn’t even appear (see screenshot below).
On the web (it’s only a webapp), when I go through the normal process to access this screen, there is a full white screen appearing.
NB: again, I unplugged all the code behind, thus my surprise.

How about this part?

What do you mean by “can you reproduce this issue”? Every time i tried to go on this screen, it crashes. Only for this screen. All other screens work well.
And when I duplicate the project, same problem: this screen crashes; all other work fine. (no surprise)

Ok. Can you duplicate the project, delete all the other screens and share a link to that newly created projects “project page”

If you share that here, one of us in the community would be much more able to help you out. It is helpful to look at a stripped down example in order to root out the issue and ensure there is no way it happens due to actions on another screen.

1 Like

OK thanks. I’ll dot that and send it to you in PM.

2 Likes

What happens when you copy the project and then open the copied project and delete the problem screen. Then create the screen again and see what happens. Will it still crash?

https://x.thunkable.com/copy/0f29c72985f1ed8bcce96ba14da47637
I made the project public with only the initial screen that had an issue. + 1 copy of this screen (without any code nor any component) + 1 blank new screen.
None of them working (in preview mode). There may be a screen property (that I can’t find) that may cause the problem

1 Like

I’ll have to hop on my computer later. This loads fine on my phone in the Thunkable companion app

1 Like

It works in my computer

Also in my phone

Hi Thanks a lot for these insights. I tried with another maschine and I could finally have the screen visible. It turns out that once the sreen crashes once, it couldn’t be displayed anymore. → @thunkable team, maybe sthg that can be fixed :slight_smile:
I had to clear the “cache” (cookies and stuff) of my browser to get the screen back. (that’s why even when I unplugged the code, I continued to have the same problem in perception).

Anyway, I finally find the bug: the table that feeds the data list viewer was looking for a variable with an accent in the name (“libellé”). This is very frustrating to lose all this time for such thing, even more as it is surely due to your update. Please pay attention (if I am not wrong) and fix it :slight_smile: For all the non-english speaker, it can cause problems.

Anyway thanks for replying today. A painful process to finally find the error, but it is resolved now.
Have a good day

1 Like

This is not new and was there from the start. You need to avoid using non-English letters and also avoid using hyphen. A variable name such as user’s ID will cause the app to crash.

Yes, I understand, as I don’t have all the good habits of professional coders. However, it worked last week, thus my astonishment. Anw thanks again for replying today!

1 Like

Hi @muneer , Finally, it turns out that is not due to the “é” but instead to the length of the variable name. The loop must be too big, thus when translated in lines of code, the number of characters in the same line must exceed some kind of limit.
So, this is entirely NOT the fault of the update, but mine as I changed names this week. Sincere apologies. + I wanted you to know this in case you encounter this issue in the future.

1 Like