Lottie Animation not working


I added a Lottie animation on my app but it didn’t work on iOS and it crashes the app on Android so it’s totally not usable.

Anyone experiencing this also? Any solution?



I have also experienced similar issue. I have tried other animations on Lottie to see if I can replicate the issue.

I have found that some animations work and some don’t. Some JSON animations are poorly created or constructed and I believe those are causing the issues. I further tested the Lottie editor (on the Lottie website) to see if I can change the layers. If you can successfully change the layers colors, size etc. then use those. If you cannot, then be sure that animation is not going to work properly.

The Lottie editor does show if the animation is OK. When I find an animation that works in the Lottie editor, I have clicked on the creator/author of that animation to see what else he have created. I am using animations from creators that can be edited in Lottie successfully. This means the JSON is structured correctly. If JSON cannot be parsed correctly, you will get errors.

Hope this helps.

1 Like

Thanks for sharing your experience. I’ve tried 3 lottie json files alredy and they all didn’t work even if I was able to change their layers.

Do you have some sample lottie json files that I can try?


Sorry to hear. This is one I tried and worked successfully. https://lottiefiles.com/4964-check-mark-success-animation

Did you login to Lottie and edited the layer colors to see if it updates correctly?

Let me know if it worked.

I did try changing the layers. This is the one I tried that didn’t work on iOS and crashed on Android. https://lottiefiles.com/11647-medal-animation

I’ll try the animation you sent. Thanks!

The animation looks fine and works fine in Lottie. Close the Thunkable Live app completely and open it again and see if it crashes again. If it persist, then this issue is intermittent. In that case, I would ask the Thunkable Team to look into the problem.

I have not tested animated GIF’s though. Maybe that is a temporary workaround. Also try to place the Animation outside of a row or column. Also make the animation element the same size of the actual animation.

Hope you get it to work.

@dmndeklerkeb thanks for this information. I had initially thought it was an issue with the companion for me but your example file works fine.

Much appreciated.

Do these JSON animations still work in Thunkable Live? I can’t get one to animate. It just appears blank. The GIF for the same animation on https://lottiefiles.com works in Thunkable Live but I’d like to use the JSON version.

(Documentation: https://docs.thunkable.com/lottie)

I still cant get JSON animations working… any updates?