Issues with BLE read/write byte array blocks

I’ve been testing an app with BLE send/receive and was working fine up until yesterday afternoon when all of a sudden every attempt to use any blocks with send or receive crashes the app.

I tried an old app that was working and it also crashed.

Could this be a new bug?

@domhnallohanlon
@jaredgibb1
@cassandra

2 Likes

Thanks for reporting this @muneer


Hey everyone,

My name is Matt; Muneer has been assisting me with prototyping an app-integration with a blood pressure cuff device a client of mine is wanting to integrate into our services.

So far it seems like we’ll be able to use Thunkable for this integration, saving a lot of time and $$$ for my client, but as Muneer pointed out there’s some sort of bug with the BLE stuff.


Just to provide some background on the project:

  • My client is the director of operations for one of the largest hospital chains in New York
  • One of the charity services offered is blood pressure monitoring, and early alerts, for fire fighters in the NYC area
  • We’ve found a device that we can purchase a ton of, and distribute them to the guys
  • We now need to build an app that can easily collect the info from the BP devices, and upload them to our cloud

I’d like to use Thunkable for this, as it seems to really reduce the dev-time needed for such a project. (Especially since it’s a charity thing, we’re trying to keep costs as low as possible)


Anyways…

  • any updates on this functionality would be greatly appreciated.
2 Likes

what kind of device are you connecting to? the cuff mentioned below?

this is new to me, i haven’t heard other issues yet.

1 Like

I tested multiple devices. I have OBD2 for car service codes which was working fine but now every time I use the read block it crashes.

I tried connecting the mobile with the LED lamp at home which again a Bluetooth enables lamp but the same.

1 Like

any chance you can share a minimal example that would demonstrate this issue? would be great to iron out a lot of these bluetooth issues as soon as possible!

2 Likes

I must say that there is a lot of improvement today when I tested the BLE project and the app is not crashing when reading now but when sending byte array (transmit byte array) then it crashes.

Yesterday all functions were leading to app crash.

This is a demo project that works with my device
https://x.thunkable.com/projectPage/6273fcd731028c0012362a50

[Update]
I must add that the project I’m helping @multitech-visions requires transmit and receive byte array therefore this becomes a show stopper.

1 Like

have you connected with lightblue yet?

I saw something earlier where a device was sending notifications that are byte arrays but not sending a message

2 Likes

This should answer your inquiry

1 Like

so you can’t receive anything from it, but you should be able to send a message?

Yes this can happen because Thunkable does not actually read notification (which in BLE terms are broadcast messages).

When I send the message as text I can see it in my BLE device but when I try to use byte array the app crashes. Trying to read byte array gives error too.

I just ordered a arduino kit to try and help debug the BLE issues.

2 Likes

I showed you the characteristic UUID for the port I am trying to write to. This is a programmable device so I’m happy to send you the setting of the other port for reading (transmitting from the BLE device to my app).

2 Likes

Thank you all for the continued work to get the BLE integration working! Your efforts are much appreciated! (^_^)

It would seem there’s an error. I just bought an arduino to begin testing with this. Is there another device that would be relatively cheap that would suffice in your opinion?

2 Likes

I was thinking of a crazy idea but haven’t tested it yet.

In MIT App Inventor, you can choose between a Bluetooth client or a server. If you develop a Bluetooth server then you can actually have the app running in an Android device then you can connect to it from your Thunkable project while you can design the MIT project to display whatever received from your Thunkable project.

2 Likes

wow. that’s so much simpler than I was planning! Would you want to connect via zoom and chat more about this. I’ve not used AI2, though i’m sure some of my coworkers have.

No pressure either way but would love to help get this all figured out as soon as possible.

2 Likes

Sure we can come to zoom. I’m with the family right now enjoying Eid holidays (It is the holiday after the whole fasting month of Ramadhan). But can plan for tomorrow or whenever convenient to you.

2 Likes

Any news or updates on this? My client is getting a little squirrely… :joy::muscle::+1:

1 Like

You should be able to read a byte array at least. Can you try that? It should be partially fixed, I believe. Not at a computer now but can check on the overal status of this in the morning.

2 Likes