Invalid API Key - Airtable Data Source

Hello thunkable community. I am having issued getting my Data_Viewer_Grid and my Data_Viewer_List to connect to my airtable. I have entered in the correct API key, I know this because I can get the Airtable Extension to connect and work properly.

Invalid API Key

Please check your API key and try again.

hey @dtuandoo9ya :wave:

Welcome to the Community! This is actually still working but there’s a minor issue with the frontend that we’re working on fixing at the moment.

As a work-around, all you need to do is refresh your browser and your will be able to connect to your Airtable base.


is the frontend issue the layout issue?

I am having the same issue where it is saying my API key is invalid however I am not understanding why since my API key seems to be working for everything else. This is for when I try to make the data source from Airtable for Data list viewer

I’m trying to connect a Data Viewer grid to an Airtable DB.
I get my API KEY from my account page, copy it (or write it manually) to Data source API KEY box, and when i click “Refresh” it gives me Invalid API KEY error.
I’ve already tried regenerating the API KEY and inserting the new one but with no luck, same problem.
I even tried using another pc and browser, thinking there could be problem with cache or something similar but the problem persist.
Any suggestion on How to solve?


I have been receiving the same problem and have also tried regenerating the API key to no success. Hopefully someone from Thunkable sees this so that it can be fixed.

1 Like

We’re actually just working with these components at the moment @supermanbritt and @Giuseppe_Geppo_Catta and we haven’t encountered any errors today.

Can you send a screenshot of the error you are seeing?

Are there any error messages in your Console?

1 Like

This is what I keep getting even though I am copying and pasting the API key from my Airtable account page but even after I regenerated my API key it still says that it is invalid.


The same for me.


Could It Be related to the screen name where the component Is placed?
I noticed that none of us have the default screen name (I think I already tried creating a new app with the default name but I’m away from the PC at the Moment so I can’t test It).

1 Like

I don’t think so because I tried making a brand new app and only added the data source and I got the same error.

I have the same problem, tried to regenerate API key countless times now and always get the “Invalid API Key” error message. Tried with both default screen name and custom ones. API Key works with other integrations.


Hi admin,

Same problem for me, could not add new data source from air table. Please have a look on this matter. Thanks.

1 Like

Same problem

1 Like

Hopefully the Thunkable staff can find a way to fix this soon.

Why do I have to experience all possible bugs?? :sob: :sob: :sob:

Invalid API Key here too :frowning:

1 Like

So, it seems there are two almost identically named posts in the community - merging them all here to reduce confusion.

As I mentioned above:

Can you please try this and let us know that it’s working for you on the second attempt.

Thanks @mindsmatter @Giuseppe_Geppo_Catta @supermanbritt @danielsfd @baquang2910l0mkv @jocelyn.humphries1tb @neuheisser

1 Like

I tried that and it still is not working I tried refreshing it as well as using hard refreshes and it still does not work after several attempts.

1 Like

@supermanbritt - did you try clearing your cache?

@domhnallohanlon I just tried that and sadly it is still not working .