Image/video component

Dear developers,

very nice, that the image component in iOS thunkable is capable of showing GIF files :clap: . I use cloudinary for storing and processing of images and videos.

There are people, who say, that GIF is actually too old and mp4 or webm is much better. Will you go towards these video formats and make a component to show videos or will you stick to GIF (cloudinary can produce both)? - This is important for me to plan my app concept.

No hurry, Thanks in advance,
Cheers, User81

Video player in thunkable classic can handle mp4 from cloudinary.

Unfortunely, the thunkable X webviewer cannot show these mp4. Has anybody a solution for playing mp4 on thunkable X?

GIF can be played by the webviewer, but is approximately 20 times larger

thanks for your help!


If you give me a link to any .mp4 file that you do not play in WebViewer in Thunkable X, then I’ll try to see the solution to this issue.

Try the test link

Does WebViewer on your device play this file?

1 Like

Hi actech,

Your help is highly appreciated! Unfortunely, the link to the big_buck_bunny.mp4 shows the same result like my link: (,h_512,w_512/v1531061173/oxdxmtafipihpvzaqxgo.mp4)

Error loading page
Domain: WebKitErrorDomain
Error Code: 204
Description: Plug-in handled load

Iphone 4s, iOS 9.3.5

Thanks in advance,


You are right, WebViewer displays an error, but on iOS 10.3 (iPhone5) after that the system player is opened and the file is played, and on iOS 11.4 the playback occurs in WebViewer without error.

I correctly understand that on your Iphone 4s, iOS 9.3.5 system player does not appear?

Try playing around with the WebViewer.allowsInlineMediaPlayback property.

Try to open my link in an external browser using the “open link” block. This way you also do not play the file?


Thanks!! Great solution, now it plays the file without problem in the webviewer window :grinning:

the strange thing is, now I cannot reproduce the error, no matter which option is enabled or disabled!
Maybe some kind of bug.

As solution I think of the following:

Go to Webviewer advanced tab-> to the bottom

Disable all the 6 following options:



Enable all of them.


Thankgs to @actech for brilliant solution