Google Play API level 28 Requirement [August 2019]

I recently submitted an new app and Google play console shown this warning asking my future apk from August 2019 should target API level 28 instead of level 26 now.

I’m using Thunkable classic Built Date: May 23 2019, Version: v1.0-1335-g5d146408e,
Thunkable Live Version: 4.02.

May I know that Thunkable Classic will be updated to comply with the latest Google policy or Thunkable team will still keep operation after 2019? Thank you in advance.

The warning:

22

3 Likes

Hì all, im unable ti publish on playstore. Im geting this message, someone can help me? thanks in advance

Target API level requirements starting from August 2019

Notice:

The current target API level of your app is 26, but the minimum target API level must be 28 to make sure the app is based on the latest APIs optimized to ensure security and good performance.

Starting from August 2019, the new apps must have the Android 9.0 version as a minimum target (API level 28).
Starting in November 2019, app updates must target the Android 9.0 version (API 28 level).

Suggestion:

Change the target API level of your app. [Find out how] (https://developer.android.com/distribute/best-practices/develop/target-sdk.html).

APK not optimized

Notice:

This APK ensures that unused code and resources become available to users. The app may be smaller if you have used the Android App Bundle format. If you don’t optimize the app for device configurations, the app will be larger to download and install on users’ devices than it should be. Large apps register a lower percentage of successful installations and take up the storage space of users’ devices.

Resolution:

Use the [Android App Bundle] format (https://g.co/androidappbundle) to automatically optimize device configurations or manage them independently with multiple APKs.

This isn’t preventing you from publishing.

It’s simply a warning to let you know the this target level will be required from August onwards.

Please proceed with publishing you app as normal

Thanx for raplyng. But there is not a rollout button

It’s only a warning.

Don’t mind this.

Yes. Even I get it sometimes…

Thnx guys i solved. Was a mine mistake.

1 Like

How did you solve it?

I have the same problem

How?
Please

Is thunkable going to be updated to target API 28?
I know there was a similar issue last year that was resolved but I haven’t found any answers yet.

App crashing on Android 9, also google says it doesn’t target the latest API when uploading the APK. Is this related? Seems so.

Android 8.1 is fine. All the app has is an webviewer on the first page and an unused localDB component, nothing else.
Anyway, here’s an example of what happens when trying to run in Android 9:

Screenshot_20190705-152053 Screenshot_20190705-152048

Any thoughts on this?

In order to provide users with the best Android experience possible, the Google Play Console will require that apps target a recent API level:

August 2019 : New apps required to target API level 28 (Android 9.0) or higher.
November 2019 : Updates to existing apps required to target API level 28 or higher.
new apps and app updates will need to target the corresponding API level or higher.

my question is when app inventor thunkable updating API Level 26 To 28 ?

4 Likes

i have the same problem, and it’s frustrating that there’s no update from thunkable team about the issue.

1 Like

Three weeks remain until it begins to apply, probably Thunkable will fix it until then, so be patient

/Boban

This really frustrating situation for all the developers.thun

1 Like

Target API level specifications from August 2019
Warning :

Your application is currently targeting API level 26. However, it must target API level 28 to a minimum in order to benefit from the latest APIs, which are optimized for security and performance.

As of August 2019, new apps will need to target Android 9.0 (API level 28) at a minimum.
Beginning in November 2019, application updates will need to target Android 9.0 (API level 28).

Advice :

Change the target API level of your application

APK not optimized
Warning :

This APK creates unused code and resources that are sent to users. You could reduce the size of your application with the Android App Bundle format. Because you do not optimize your application for device configurations, it is larger than necessary for download and installation on users’ devices. Large applications have lower installation rates and take up space on users’ devices.

Resolution:

Use the Android App Bundle format to automatically optimize your app for device configurations, or manage it yourself with multiple APKs.

Target API level specifications from August 2019
Warning :

Your application is currently targeting API level 26. However, it must target API level 28 to a minimum in order to benefit from the latest APIs, which are optimized for security and performance.

As of August 2019, new apps will need to target Android 9.0 (API level 28) at a minimum.
Beginning in November 2019, application updates will need to target Android 9.0 (API level 28).

Advice :

Change the target API level of your application

APK not optimized
Warning :

This APK creates unused code and resources that are sent to users. You could reduce the size of your application with the Android App Bundle format. Because you do not optimize your application for device configurations, it is larger than necessary for download and installation on users’ devices. Large applications have lower installation rates and take up space on users’ devices.

Resolution:

Use the Android App Bundle format to automatically optimize your app for device configurations, or manage it yourself with multiple APKs.

It is just a warning for the time being; but the Thunkable staff has to upgrade the API support within the next 3 weeks or we’ll really have trouble.

1 Like


sir, when we are gonna recieve API level 28 upate?