Firebase login API Key Invalid error

I’m been going crazy for the past few hours…

Simple Login with Firebase… Have API and DB URL

Created simple project to test it… And I get API Key error “API Key Invalid”

Very simple… button, signin, label button call sign in with 2 parameters email: test@test, pass: “test1234”… capture result in label…

Design View

Blocks View

Thanks for any help!!

@app.greateats.cow Are you testing on the WebViewer or in the companion live testing app?

I’ve haven’t been able to login through the web this week. I keep getting a ‘API Not Defined’ error. This is a bug on the Thunkable side. Works on the live test app though.


Mmm interesting, it seems it’s affecting the Firebase Database too.
The only way to see if it’s working is on the Live Test App as you mentioned.

1 Like

Hi Darren,

Thanks for the reply… I was testing on both Webviewer and the Android Thunkable app… BOTH were not working… a short while ago… the Thunkable app started working… …

Thanks for the help and great youtube videos


Hi Sofia,

Yep… Noticed that too…
Being new to Thunkable, I thought I was doing something wrong…

Thanks for taking a look

Crazy, but not going crazy…

That’s okay i was new too! But i learned a lot i still had questions but i still got though it

I’m getting the same error now testing from the web. I triple checked the API key and DB URL.


@app.greateats.cow Your screenshots seem to be broken unfortunately so it’s hard to say for certain what’s going on here. You can just upload a screenshot directly to the community, there’s no need for third-party hosting.

@levelupjamdownf3n1 can you share some screenshots or a project link so we can look into this?


what your problem?

as outlined at the start of this thread, I’m unable to connect to fire database in the web app. Only works from mobile Thunkable app. I’ve attached a screen shot showing the error when I try to connect from web (Your API key is invalid…).


I got the same problem. My APP works on mobile device, but on web live doesn´t. I tried Chrome, Firefox and IE and appeared the same error.

I have the same issue “API Key is invalid, please check you have copied it correctly”, I have copies it correctly yet the error keeps happening