Datasource not always showing values, but it works

Hi everyone,

When I open a screen there’s a Data source that should be showing. Sometimes it shows correctly, sometimes it doesnt. When it doesn’t, it doesn’t show the values but, if I click on any of the row, it works properly.

This is how it should look like (sometimes it happens to work and show values correctly):

This is how it looks few times:

Altough values are not shown, if I click on one row, it correctly show me the values.

The label under the tab shows the value I have clicked
1 is Image, 2 is Title, 3 is Subtitle, 4 is the Price

Everything works correctly, even though the data are not shown
Blocks are very simple, literally click->navigate to screen (where the data sources should be shown)

Someone can help?

1 Like

It does the same with values from Airtable.

I have always used them and i’m quite confident, but can’t understand why it’s happening.

1 Like

Is this using a DVL (Data Viewer List)?
Is it the default DVL or a custom made one.

If the default then change the layout to some other from the list and see if the issue persist.

If a custom layout then for this test phase choose one of the already existing layouts.

1 Like

It is Data Viewer List
I tried different layouts (title, subtitle, image/title, subtitle/title) but they dont work.

Also now i’m experiencing the same problem using Airtable (here again, doesn’t show values but it works if I click on them).

I really, really need help on this!

1 Like

I don’t have clues on this. Maybe if you share the link to your project to have a look.

1 Like

Sure, you can try this link.

It works good when you start it for the first time, then when a screen changes, every data sources (airtable included) become blank

1 Like

Can you guide me the steps to produce the error instead of finding my way around?

1 Like

Sure! The fact is that the errors shows itself automatically, usually when you changes screens or after doing few actions.

When you open the project you can navigate through the menu into the DRINK COST screen.
Once you filled the text_input with a number (milliliters) and chose a bottle of liquers, you can press the FIND DRINK COST button.

Once there it shows the drink cost page.
After few plays around, it happens to see all the data sources blank.
Data viewers are everywhere, starting from the bottom menu, you can find one in the Drink cost page, on in “Saved”, more than one in “Inventory”, one in “Info” too.

Thank you very much for your help. Really appreciate it.

1 Like

I tried it few times and stops at this stage

It seems the app is trying to retrieve data from Airtable and it fails because I don’t have a valid connection to your Airtable base.

Therefore I will not be able to dig further.

1 Like

Those Data viewers are not linked to Airtable, they are in local storage.
The only Airtable-linked is the one in the “Info” screen (from the menu)

1 Like

Then there is something else causing it to fail and not continue preventing further investigation in the original problem.

1 Like

The bug you are experienced should be now be fixed, it’s a known bug that happens when the drink cost has too many decimal numbers and the block “get decimal number” seems to not be working properly.

Hope it’ll go smoother if you fancy trying again

Some menu options do work

1 Like

I’m trying the app using as responsive web app, and it seems to work. But it still doesn’t when i try it on my device.

1 Like