Data sources DataBase can't be blank. And it's slower than localDB

Since there seems to be few known bugs in the platform, I think it would be a good idea to have a list that contains allof them so that if you have issues with something you can come here and check if it’s a known bug so you can avoid to waste time fixing it.

Like I just found out that the “update value” of the data sources database doesn’t work.
It only accepts certain data, like for example if I try to update to the number zero it doesn’t work, but it accepts zero in string, but it also depends on how I named the column of the db, I don’t know

Hi @maxb, @actech has shared his bug tracker project:
from this thread:
Bug Report - Text Input on Cloned Row Updates Original Component

Hope this helps :slight_smile:

1 Like

I will look into this more

Also, regarding the issue that you found. Here is a possible work around: The things that worked no longer work

Maybe it doesn’t accept 0 because it thinks it means false? I once set a variable as 0 as a place holder and when tested it determined it as false. Not super sure though.

1 Like

I don’t have the answer right now ,but i think i kinda get it also i did research this online while looking for a coding project

Thank you @mythi for this,

good idea from @actech,

i just remixed it to look a little bit more catalogued in order:

I was gonna add my bug of the data sources myself, but it look like I can’t even create a new database

It’s not only about simple numbers, or not making math operations, it just doesn’t save to the database if it doesn’t like the column name, like if I give it a cloned label id to the column ‘Name’, I can save it, but if Igive it to the column ‘Price’, I can’t save it

1 Like

Ok so, I found the problem,

data sources databse mistake

if you leave the blank spaces in a new row, those column won’t work.
Also the number zero problem seems solved, it was maybeconnected.

(Unfortunately it seems that the data sources database, which IS NOT the same as local DB, is way slower than local DB making the app unresponsive)

1 Like