Crashing When opening Blocks

I need some help. Whenever I try and open the code to my app, the interface opens it for a second, freezes, then crashes.
https://x.thunkable.com/projects/5d9656c8e7d3466febf5726e/131f1968-64c1-42cf-a114-1c1e398f38ad/designer
I switched one of the text input names, then went to correct the code, then this happened. I’ve tried multiple browsers, multiple os’s and still have had no luck. Does anyone know anything that could help?

I make your project without blocks. Something broke in the Block Editor.

https://x.thunkable.com/projects/5db3619ef5f72c2a660cf72d/project/properties/designer/

1 Like

Hi @af4familyic6ost

Can you tell me a little more about your project please;

How long have you been working on it?
And, when was the last time you can remember that the blocks editor did open for you?

I have been working on it since October 26 I believe. I was working with the blocks earlier, had to redo part of my UI so I deleted a couple of buttons. I then renamed them so I could distinguish what did what, then I tried to go back to the blocks to reassociate the buttons in the code, and it just kept crashing on me.

Today is October 25…do you mean September 26?

1 Like

Sorry yes that is what I meant

1 Like

The error -

image

The :warning: says that you have copied those blocks from other screen and pasted here, or made blocks & deleted the components :thinking: :neutral_face:

Thanks! :blush:

P.S. I got this screenshot by clicking the screenshot button incredibly fast when the blocks part opened :sweat_smile:

2 Likes

I think that it could happen because of the app initialization blocks.

I looked at the source code of the project on the device and in addition to these 3 mistakes to see what all the blocks app initialization in Main.Open and Button1.Click refer to incorrect variables. The question is how it could happen, if only removes the components?

1 Like

Might be, coz it already seems that he has used a lot of in-app variables.

Thanks! :blush:

1 Like

Sorry for the delay: here is a working copy of your project. https://x.thunkable.com/copy/8ef1cf8c601588d8ae34ef536307d8b0 I manually fixed your project - we’re still working on fixing the bug that caused this (don’t delete time inputs without deleting the related blocks for now)

3 Likes