[SOLVED] Known good app crashes as of today, with no additional blocks added

Hello. Today we went on our app to add another feature. It was small, but the app stopped working after we finished it. Like it was stuck on the first screen and would not run further.

We traced it back (thank goodness we make backups) and we found that when having a known good app without touching the Design or Blocks menus, it works fine. The screen boots up and we can run through our entire app.

But now we take that same app and merely move the page in the Blocks menu, boom, the app gets stuck on the defaults state. No buttons works and it just looks like it stop running as soon as it starts.

Here is the app link of how it is broken: Thunkable

Try pressing the buttons, nothing will work. Loading icon is endless.

Here is the same app (named differently) but working just fine with all the same blocks.

Note that the normal behaviour is that the first screen goes to a google sheet and fetches some data. When finished, you can scan for a certain product we manufacture.

Could we get assistance with this? We do have a paid account and heavily rely on Thunkable for our products. We cannot develop further since we can quite literally break any app in our account now by merely moving around in the Blocks editor.

Hello @bitbanggaming :wave:
Thank you for creating this post. I understand it is frustrating.
These type of issues are caused by the “When screen starts/opens” blocks.
I see you have the same blocks on both projects.
A suggestion that I have is to use only the “When screen opens” block because it is activated also when the screen starts. This might solve the issue.

Hello @ioannis !

Thanks for replying back so quickly. I was not aware that the open and start conditions could perhaps cause an error as I have no seen this happen before with other apps we have created.

I went ahead and deleted all the start condition blocks for every page and now have this new modified project to share: Thunkable

As mentioned I never seen these blocks conflict before but I could have gotten lucky with race conditions. However, this has not solved the issue quite yet. Could it be perhaps some sort of memory limitation? I write firmware at my day job so “coding” in blocks isn’t too bad but I often am unsure how to troubleshoot without a debugger or compiler error messages. I resort to outputting to a label but unfortunately the screen doesn’t run at all to debug in this manner.

Any other suggestions?

Once again, thank you again for the quick reply and taking a look.

As some follow up info. I made a copy of the broken one and just deleted the screen. Now the app works as usual. My thought is:

  1. Either the 1st screen had an issue and is possible to arrange the blocks in a way to make it work.
  2. Or the 1st screen cannot be fixed and deleting, then re-building the screen is the only way to “unstuck” the app.

Curious on your thoughts.

Hello @bitbanggaming :wave:
It requires a lot of tests to find what exactly is causing the issue.
In general, I disconnect some blocks until it stops crashing and then start putting them back in.

@ioannis So I tried as you suggested. I did find a block that looked like it might be causing problems. So we took it out but that page just doesn’t behave like it used to, even with trying to delete it block by block and re-building it block by block. It’s like something on the back end got corrupted and now everything I try doesn’t seem to work with much hint why. So the theory of a corrupt page might be a valid assumption.

I wonder if the bug I am experiencing is related to the last update for Thunkable that was around 2 days ago? Older backups of the app do work so I do not think its a device version problem on our end.

Anway, we are now trying to make the page completely from scratch to see what happens. I see that there is a plan where there is an offer to meet over the phone for advanced support. I personally think this is a bug that needs attention and I am okay working with Thunkable to address it. May I purchase support for this issue? I also noticed on my current Pro plan there is Technical Support. Is there a number to contact someone in Technical Support for better one-on-one assistance?

@ioannis Quick update since last message. Now if I try to repeat deleting the first page, the next screen does not function either. Not too sure what is going on and at this point I welcome the phone Tech Support.

Hello @bitbanggaming
Thank you for sharing an update.
Deleting the entire screen will create more issues because you initialize many variables there.

To access the support that is available for PRO users and above, click on the Help icon and select “Contact Support” in the top right Menu bar in your Project Page
Screenshot 2023-07-06 at 10.54.50 AM

We’ve discovered an issue related to a recent release where using a function with an output (return) will cause all other components on the page to also not function. Based on the project above, it looks like that is the culprit of your issue.

I do sincerely apologize for the inconvenience here. We’re working now to fix this issue as soon as possible. We’ll keep you updated here as we learn more.

1 Like

I feel it is worth noting that is not just the function with the returns. it is all functions in general causing this issue.

@ioannis thanks for showing how to get to that link. Very helpful and wasn’t aware that it was even there. Much appreciated!

@matt_conroy thanks for confirming my block suspicion. The block causing us heartache was the function with an output return. However, even after deleting it, sometimes it would fix it and sometimes it would not (usually not), and the whole screen breaks, along with the app. At this point, we went to a version of our app that is about 2 weeks old, and we painstakingly used the broken app in another browser, and rebuilt our recovered app manually to get it back up to date. We are almost at a good spot (where we were before the function return bug); the app seems to be stable. Along the way, we have been scrubbing our app of functions with returns (hard I know but we have to get this app done for our customers). We still have one more page that we accidentally had a return function output and it indeed crashed the app when going to that page. After we promptly deleted that page, we seemed to have dodged the bullet this time since it seems stable. We will update tomorrow when we make our final app edits. Rooting for you Team Thunkable!

@patanellaxq6lk from our experience, its as @matt_conroy describes, its only for blocks with function return outputs. We have a fair amount of functions with no returns (and deleted empty return blocks), and the app we have seems to be working okay. We will report tomorrow if this is still the case.

Aha! I experienced that today but couldn’t figure out the cause. Thanks for posting that explanation. I’ll go change the function for now.

@bitbanggaming @tatiang @patanellaxq6lk Thank you again for your patience. I would like to let you know that we have now officially released a fix for this bug.

Our engineering team has recommended moving any block to the screen (like an event block) so that the code will recompile.
Please let us know if you have any other questions or feedback for us.

1 Like

Great, thanks for the help!