Cloned image not filling URL picture

I haven’t had any issue with this until just recently. I haven’t changed any code on this screen. Older versions of my app work, but when I copy those version and change anything my problem occurs. Very frustrating.

I have cloned elements and they all fill with different items. (see pic below) Everything works perfectly except the “from image” block that is highlighted in yellow. In my app it just has a blank.

Things I have tried:
I have tried different image links. I have tried putting the “from image” block in it’s own loop. I have put in a “make visible” block to make sure it shows.I have uninstalled thunkable live and restarted my phone. Is this a bug with a recent update?

My app and my phone are completely updated: Thunkable -197 iPhone8 -13.5.1

Hey @ryan_hall_apps

your local variable y … is that initialised as a number or a string?

Incidentally, what is the expected value of y? To help you troubleshoot, can your try replace the 1 + app y blocks with a whole number and see if it updates the corresponding image.
If not, double check the URL you are using - that might be the source of the error too.


Good thought. I should have checked that first. I changed the images to buttons and set the background image to the URL. This was a mess to do but it worked, and is probably what I should have done in the first place.

I can check the y variable in an older version when I’m in the computer again