Clicking on Data Viewer Image not Working

I am following the Thunkable Academy course that incorporates the Data Viewer along with my students. About 25% of the class is getting a problem where they click on a Data Viewer item, but it does not execute the code in the blocks (in this case, store the row that was clicked and navigate to the next screen). It simply just stays on the screen.

Here is the Data Viewer that has been populated with information from a local table:

And here is the code that goes along with it:

As well as the local table where the data is being taken from:

Any idea what the problem could be? I put a debug label in there to see if the ‘row id’ block was returning something and it was. I ran out of ideas on this one so hopefully someone can help!


Initializing a variable as an empty object could be problematic. Perhaps that’s okay but the first thing I would try is to remove the create object block.

You didn’t mention what debugging you’ve done. For example, what happens when you:

  1. Remove the set variable block and just have a navigate block there?
  2. Change a label’s text before the navigate block. That will tell you if the Item Click block isn’t working or the navigate block isnt’ working.
  3. What happens if you delete the when Data_Viewer_Grid1 Item Click block and replace it with another one? Occasionally, blocks get corrupted or need refreshing when a component is changed/added.

Hello Tatiang,

Thank for the prompt response. I will recount some of the debugging I’ve tried below, beginning with your suggestions:

  • When it is just the navigate block inside the ‘when Data_Viewer_Grid1 Item Click’ event, it successfully goes to the next screen, so the problem has to be within the previous block or the table

  • I am not sure what you mean in suggestion #2, but the Navigate To block is working. It just seems to get caught somewhere in the previous block.

  • I had previously tried deleting and reconstructing the ‘when Data_Viewer_Grid1 Item Click’ event. Same outcome.

Other things I have tried:

  • Deleting and remaking the local table
  • Taking out items from the table that had special characters or something out of the ordinary (dashes in phone #'s, @'s from email addresses)
  • As stated previously, I also tried to make sure that ‘row id’ was returning a value with a label. When I click on the top-left person I get this, which seems to be correct:

What about that? Does it make a difference if you leave the code as you had it in the screenshot but just change that one block?

If that doesn’t help, I’d suggest posting a link to the project.

Sorry, I forgot to mention in my previous post that I tried that with no luck.

Here is the link for the project. I appreciate the help!

I even tried to re-create the entire project again with a completely different table to no avail. If I take out the ‘row id’ block from variable setter as such:


It navigates to the next screen perfectly fine, so it has to be something with this particular block (even though, as previously stated, it has a value).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.