Check your firebase entries, some characters are not allowed in the keyfield

Ok so,
my app is fairly complicate at this point, but it works, on iPhone.
And it doesn’t on Android.

Here, the last step.
Why? No clue.
@Mark I think this is something for your knowledge.
The problem seems to be in that username result, which is just a join from 2 text inputs.

Everything works, on android, until that last step, that it doesn’t compute.


At some point I have to save some values to firebase, and iPhone does it perfectly, Android does it partially.

FIrebase rules are completely open to esclude other reasons.

Anybody any clue?

1 Like


That’s pretty strange. Any chance you can create a really simple app which demonstrates the problem?


Ok soo, the problem was that in the name I was saving there was a “.”, a point.

And firebase doesn’t accept it in the key.

I tried to use the realt time db block to have an error reportbut it didn’t work, dunno why.

So it’s solved the mistery, thanks Mark.