Centering textbox hint

Some of my textbox are align perfect. But i still got 3 more that are not align but i double check, they are same setting with the others the align. when i type evrything is align perfectly, it just the first look the hint… text touching the borders. is thier a very important advance setting that i missed? please helpme know

1 Like

Can you share a screenshot please @DevilLooper?

Also, please double check the padding property on each of your components.

Thanks

I already did sir. My padding on the left is at the 40 but still same result, but my other textbox fine

Both of those TextInputs look the same to me?

Do you have one somewhere else too? Does it also have rounded corners??

Sorry to dig this up but I am facing the exact same issue now without changing anything. Do anyone know a possible solution?

Hey @aliencaocao, would you mind sharing a screenshot so we can compare to what @DevilLooper had?

Have you tried adjusting the left padding of the text_input to move it more towards the center?


I tried adjusting left padding. Changing it to 15 and then 0px makes no difference. I find that it only occures if I put it inside a column. I tried with a fresh textbox put inside a fresh column with default settings and this bug will occur. However similarily it only occurs on this screen of the app, while other screens are working fine with the exact same setting.
Weird thing is the moment i type something into that buggy textbox, it reverts to normal, and maintains normal even if I delete all the content I typed in. Also, both checkboxes in picture are under the same column and exact same setting, however only the upper one has this issue. I tried putting a fresh new textbox into this same column, and the bug also appeared on the fresh textbox.
This bug only happens on android (I tested with EMUI 10.1, Android 10). iOS is fine.

1 Like

Hey, did you find a solution for this apart from centering the hints? I have the same problem and need the hints to be aligned to the left…

hi, sadly i havent, and no one from the community is responding to me yet