Button Width Will Not Change

I am trying to make a very simple button where I want the button to be absolutely sized to 60px by 60px so that it is round. No matter what I change, the button width only changes when I change the size of the text inside of it. Why is it not changing otherwise?

Thanks,
TJ

2 Likes

Are you using StP (Snap to Place) or DnD (Drag and Drop)?

With DnD you can set the size in the design stage.

With StP you need to change the size of the button to absolute and then set the size.

1 Like

Hi Muneer, thanks for your prompt repsonse. I am currently using StP. I did change the button size to absolute before I set the size. I even tried to set the size in blocks after and it still will not change the width.

Another weird thing – it is the correct size in the editor:

But it comes up the wrong size in the in-app preview and live preview (as in my original post).

3 Likes

see


i have changed height and width to Absolute size 50
@tbocchino4

In the Screen Opens set the width of the button to be the computed height. This will make it square.

1 Like

yes @muneer is right you can do this method also @tbocchino4

See this
image
Setting the size of the button to absolute of 100 both width and height.

Then set the radius to 0
image

You should see this
image

And this is what you see in preview

If you do not set the radius then you will get a round button.

Hope this helps.

1 Like

Thanks to both of you for your help – the problem still persists, though. I even tried @muneer 's idea of using blocks to make it the computed height/width and still the button’s width remains unchanged.

Could it possibly be something somewhere else?

2 Likes

See this demo
https://x.thunkable.com/projectPage/620c09cb5872fa001174adc6

1 Like

Thank you @muneer for your help. I created a new project and it seems to work now. It must have been another setting that I adjusted in the button or the screen. If I ever find the answer I will update.

Thanks again!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.