Bluetooth Function won't Transmit or Recieve

I have created an app that connects to a Bluetooth module for monitoring and controlling temperature on an Arduino Uno. I have tried it with both the SH-H3 and HC-08 modules and while I can connect to the module over bluetooth I am unable to send or receive strings. I know that the module is working fine based on the fact that I can communicate with it over a 3rd party bluetooth program such as Serial Bluetooth Terminal, but I just can’t get the Thunkable app to work with it. I have a similar app created with App Inventor using an HC-06 module that works flawlessly. Any help with this would be greatly appreciated.

Hey @colsen2022jb33x welcome to the Thunkable communtiy!

Do you mean HC-06?

To start with, make sure you have your location sensor enabled and that you are installing the app on your device.

Let us know whether or not that works for you.


No, it is an SH-HC-08. I am installing the app on my device. I also have the location sensor enabled.

@domhnallohanlon I have now gotten the transmit function to work. However the receive block still appears as nothing, however there is no error, and it does not show up as undefined. It is just an empty box as though nothing is being received. However I know the bluetooth module is transmitting data, as a different bluetooth terminal app is receiving it.

Anyone have any ideas on this?
I have tried different UUID’s for transmit and receive, different BLE modules (HC-08. HC-10) with no success. I can transmit, but when receiving no information comes through. This appears to be a very common problem and I would very much like to solve it and document it well for the Thunkable community.

Try setting the first set on the transmit to 0000ffe2

And receive to 0000ffe1

i have the same problem described in this post. With my HM-10 BLE module i can transmit but i can receive (i receive only “???” chars). Is there a solution today?
I setted UUID “0000ffe1-0000-1000-8000-00805f9b34fb” for transmit and this is ok.
I setted UUID “0000ffe2-0000-1000-8000-00805f9b34fb”, “0000ffe1-0000-1000-8000-00805f9b34fb”, “0000ffe0-0000-1000-8000-00805f9b34fb” for receive without any success.

Thank you.

1 Like

Is this device sending ASCII characters or Hexadecimal?

Are you using Android device to communicate?
If YES, then install one of the BLE scanners to check the send/receive UUID instead of guessing.

Yes, I am sending ASCII chars. I am using an Android device.
The UUID detected on Light Blue is 0000ffe1-0000-1000-8000-00805f9b34fb.

1 Like

I know you send ASCII.

The question is: What is the device expecting? ASCII or Hexadecimal? As string or as byte array?

My device expect ASCII string on a serial port of HM-10. I need to send an ASCII string from Thunkable APP to HM-10 BLE module, than to my device (microcontroller connected to UART port of HM-10).
With the same mode, i need send ASCII string from my device to Thunkable APP, but i can’t it now.

1 Like

HM-10 datasheet recommends sending a wake-up string first and wait to receive “OK+AWAKE” as a response.

The “wake up string” is suggested if the HM-10 is in sleep mode, my HM-10 isn’t in sleep mode. I tryed to send an ASCII string of 100 chars length, but i receive the same “???” chars on Thunkable APP.
Is there a way to read the ASCII string from HM-10 in Thunkable APP?

For TTY emulated devices, this means speed or parity mis-match.

how can i solve this on Thunkable X? on Mit app inventor this works.

1 Like

Send AT (in upper case) and you should receive OK

This is required to initiate the speed and parity synch.

The default is 9600-N-8-1 which should work.

this is ok, if i send AT i receive OK on the terminal serial

1 Like

Can you try

Note: that all in CAPS.
Note2: you can replace + with space.

feedback for AT+BATT? is OK+Get:099.
AT BATT? hasn’t answer from HM-10

1 Like

Your device is in a good working condition and communicating.

What else do you want from it?