Arduino Car: fails to find Bluetooth HC05

Hi,
I am designing an App that controls an Arduino car. I have designed the same App on App Inventor and it works easily. In App Inventor I scan for Bluetooth devices and a list of devices is displayed and I can select from this list.

The problem with thunkable is that it never finds the HC05. and doesnt display the list of items available.
https://x.thunkable.com/copy/6e4b6047fbe35be27e486c9c5ed7c74e

If anybody has designed a similar app they can share with me, or can offer advice I would greatly appreciate it.

Hey @alanbartley were you ever able to make any progress with this?

Are you live testing or installing your app?

Android or iOS?

Do you have the location sensor enabled too?

Hi Domhnall,
Thank you for following up on this. After a break from this project I am back working on it again.

When I scan, no names appear on the list viewer (With the App Inventor all devices appear no problem)
I have the App installed on my phone, and it is an android.
The location sensor has been enabled also.

When I search for IDs they do appear, however when I search for names it does not work.
As I said it works perfectly with App Inventor, but I would really like to get this project working on Thinkable X.

Thank you, If you can help me it would be great.
Alan

No problem at all - I’ve been meaning to do some in-depth BLE tutorials for a while now so happy to help out where ever I can.

Sounds like you’re doing everything else right - have you tried displaying the response in a Label just to see if anything it coming back?

If it’s not an issue with the response type, it might be platform specific? Are you testing on Android and/or iOS?

I am testing it on an Android.

I will experiment displaying the response in a label, if something works I will post it here.

It would be great to see some tutorials on the BLE, and get Thunkable X working with Arduino.

Hi Alan,

I’ve been experimenting with a Bluetooth App using Flora from Adafruit. Like you, sometimes the name of all the devices doesn’t appear, luckily the Bluefruit device I’m using comes with a factory name and I’m able to find it. I think it has something to do with how the Bluetooth is set up, most of the Bluetooth signals I’m finding don’t have a name.

In Thunkable this appears as a blank space if you’re using a list viewer.

I can’t recall if the HC05 modules worked like that too, maybe checking if the name you’re giving it in your Arduino code, to see if it’s visible?

Hi,
I see this topic was from more than a year ago, but I’m facing a similar issue.

i’m using a HC05 module to be able to interact with my phone. I previously used MIT app inventor and I was able to find my device. Now I switched to Thunkable and I’m not able to find my device anymore.

When I use the Arduino car example of this topic, I can’t see my device (the device name or the device id do not appear in the list viewer). Also, I don’t see my device in the LightBlue app. However, In my bluetoth phone parameter, I can see my HC-05 module and I can connect to it.

I’m on Android, I tried on the live simulator but also by installing the app directly on my phone.