App started crashing after built APK is installed


I am bringing this topic to the cummunity due the lack of response on Github bugs reporting page.

My app started crashing on Adroid (ONLY) after being installed using downloaded APK. It is crashing on specific pages wich the following components:
-. Text boxes, labels, images, anymation, buttons
-. Webviewer with HTML (URL being cleared before leaving)
-. Data List Viewer
-. Local database is being used here
-. Firebase is being used here

What I think is unique on the crashing pages is the webviewer; however, I tried removing this component and after downloading APK, install it and running it, it is crashing on exact same screens.

Also tried removing IF block, using a simple NavigateTo (with no lists), removing visible commands, etc.

App is crashing 100% of the time when LEAVING the affected screens, doesn’t matter which screen are you going to (just pressing Close button).

App running OK on Live Testing (Android and iOS), Downloaded iOS and web versions.

I cannot add a link to the project but below is the code when pressing “close” button and a screen shot for one of the affected screens:


I have been geeting below error multiple times also:

Reference ID: 5f4b6845-7c1b-4646-8d16-f95c30b57901

Error: Command failed: cd /thunkable/androidBuildServer/…/thunkableCompanion/android/; ./gradlew AssembleRelease :warning: Cannot resolve the path to “@react-native-community/cli” package. :warning: Cannot resolve the path to “@react-native-community/cli” package. error node_modules/react-native/Libraries/Image/NativeImagePickerIOS.js: Call retries were exceeded. FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ‘:app:bundleReleaseJsAndAssets’. > Process ‘command ‘node’’ finished with non-zero exit value 1 * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. * Get more help at BUILD FAILED in 3m 23s

Question: It is any one else experiencing issues on downloaded APK in Android? Did anything change on the platform that I missing?

Your support will be appreciated.

Honestly, that’s a LOT. You may have to start removing components one by one to see what’s causing the issue. Without the project link, it’s hard to pinpoint what might be causing the issue.

Edit: on second thought, this looks quite similar: Something went wrong when we tried to build your project

Maybe @jared can help but he will need your project link.

1 Like

Thanks for replaying.

What is weird here is that I have been downloading it around 20+ for Android without this issue till last week.

I also tried with older projects backups and the issue is there. I am convinced that is an problem when compiling the APK. Live Test in Android is working fine.

Need please support from Thunkable staff on this one.

José M Pandare

1 Like

Hey @josepandare02t

Sorry I missed that! I’ll jump into Github today and update reports! It wasn’t intentional. If you feel you aren’t being responded to quickly enough, always feel free to ping me directly, otherwise I am not alerted to comments/new posts on github.

Can you share a project URL with me via DM?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.