APK crashes before even starting

Hi everyone, today I exported my (first) app, installed the apk on my phone and immediately ran into a problem: the app crashed before even launching.
The first time it happened, I googled for answers and there was a post that suggested to give waiting times to see at which point the app would crash so I added a splash screen and re-exported it.
After re-installing it I ran into the same issue and I couldn’t even see the splash screen, so now I’m stuck with no clue.
Does anyone have suggestions?

Builder Link:

APK Download Link:

Did it work in Thunkable Live? If so, it may be an issue with stored variables if you’re using those. That’s just a guess… I’ll take a look your project, too.

It’s possible one of these issues is also causing the crash: [Solved] While testing on the phone I get error message as something gone wrong

It does not crash in Thunkable Live on an iPhone. I don’t have an Android device I can test this on at the moment.

I would try this:

  • Add a new blank screen. Add a button to it. Set the button to navigate to Screen 1.
    • Does the app crash on the new screen?
    • Does it crash when clicking the button?
    • Or does it crash right after displaying the umidità screen?

In thunkable live everything worked just fine, both online and with the companion app (android).
Thanks for the links, I’ll take a look

So, I tried to add another screen with a button that navigates to the splash screen and the results are the same: on Thunkable Live everything works but when I try to install it on android it crashes before even showing me anything

Okay so it’s crashing immediately on the new screen? I think you’ll need some help from Thunkable Staff. If I were to troubleshoot it further, I’d try making a copy of the project and modifying the project to, in this order, and testing on an Android device after each one:

  1. Remove any navigators from the project.
  2. Remove any web viewers from the project.
  3. Remove any stored variables from the project.
  4. Remove all screens except the new screen.

That would at least help narrow down the problem. I’m guessing it’s #1 or maybe #2 but it’s hard to know!

I did try to download the APk link which you shared on my andriod phone, I got a meassage stating clear cache and also the app has a bug . Sharing the screenshot. And the app does not open

Good News is I tried to tried to download the apk file , the app did open and able to see all screens.

Sharing the apk link , try to download and see whether you can access your app.

Also noticed that I do not see app icon on my apk sharing the picture

It could be the image which used in the app icon place but not sure about the cause of your APK link

Hope this helps.

I downloaded the app from your drive and, besides a couple misplaced text boxes, it works just fine! How did you make it happen?

Sorry for the misplaced text boxes as it happened unknowingly when I tried to remix your project. MOre over I am not familiar with drag and drop options.

To be honest I did not do anything after seeing the message that your app has a bug via your apk link, its just a instinct that some loading problem with the image as I have experienced many times like this it works successfully on the live test and web browser but not via apk… reasons where listviewer where put inside small space, text input had undefined in the hint section, images are not reflecting in datasources. Tatiang and Thunkable staffs were helpful all the time when I needed.

After I remixed I noticed one thing the App icon does not appear and when I download APK I was able to access your app.

My suggestion , try to remove the app icon and downloaded apk again and see whether its working. if it is then the problem for not opening the app is that image.

Also wanted to know what language is that ? as in the meaning of risultati…

The detailed insight should be given by Thunkable staff:)

1 Like

Ok, thanks a lot, I’ll try again without the icon and see what happens.
The language is Italian and the app is meant to calculate the flow of industrial chimneys for when you take pollution samples (I work within the environment protection) and “risultati” means results

Thanks for your information. Much Appreciated!

So I’ve looked for a way to remove the icon for the last half hour and I haven’t found it, how do I do it?


Sharing your project link, now kept the checkboxes in place. open this project link and download apk . It should work.

1 Like