Alert Box suddenly stopped working

I was using an alert all over my app for different things. I’m checking back now and none of them are working. It’s like that part doesn’t run. I tried creating a new app and running an alert there but that didn’t work either.

I had accidently deleted this alert not long ago but then restored it, and went back through each screen to relink it. At that time it was working.


Well, I’m trying to create an alert and it’s not working either. I thought I was doing it wrong and now I see that you have the same problem.
Let’s wait for an answer from the staff.

well it worked for me can you both try again also @sahilmanekialp you know that left click and left swipe click are different?

I like how you’re thinking, but I already tested it with the plain click button. Then in a whole other app. Didn’t work. This is just inside of an orders screen where the functionality was to swipe left and click to cancel an order.

Just tried again. No bueno.

it can be better if you give projectpage so that we can find problem in your code :sweat_smile:

also can you just try this project -
just press button

Ok so I think there’s a breaktrhough. It does not show up on the web preview but it does on the device. That includes the project you just sent me.

I don’t mind sharing this one Thunkable as the other has got apis and other hookups

well idk it works for me on web preview and also on device but still so basically it is working right?

well this screen is buried deep in the app so I need web preview to work. I don’t think it’s solved.

Edit: Hard reset did not work.

well so this is already said that many components dont work on web and alert is 1 of them -

so you have to use device itself

Can you link this? I am unable to find the source. The reason I ask is I was using this alert on my webviewer before and did not experience any issues

Drag and Drop Interface (Newer):

Snap to Place Interface (Older):

Yeah as suspected this is confusing two different things. I was saying that the web preview does not show me the alert but when I run it on my phone it does come up. Was not talking about publishing or webapps.

The behavior is odd because it was working in my screen earlier- and now is not.

then i think you should ask a staff

I understand but web preview and web apps are basically the same thing. If something isn’t supported as a published web app, it’s also not going to work when previewed in a browser.

1 Like

If anyone is keen enough to check and see the differences between the two (if any), the Thunkable documentation shows:

Unsupported components in Web Apps can be found in this link

Unsupported components in Live Test can be found in this link

Happy Thunking!

Thanks Muneer. I am suprised since this component was working in the web preview. I guess I will mark this solved

1 Like

Not supported does not mean will not work. It means it can stop any time and you cannot complain.