Where is the Media DB in the new UI?

Hey everyone! I am using the new UI in thunkable and can’t seem to find the Media DB component. Where can I find it?

Did you search the forum before posting your question?

1 Like

yeah, but i could not understand it, could you explain it to me more thoroughly?

1 Like

Hi there,

You can find the media DB in the Camera blocks.
The block ‘URL from uploaded file ’ will upload the named file to your Cloudinary media DB, then return the URL this file is now hosted at.

You can add your Cloudinary DB info to your app project in the Settings panel.

I have to make a cloudinary account for that, right?

Also, how do I write the url for the file, if I’m getting user input from the camera?

i was trying to use the ocr function and it required the media db component. now im trying to figure out how to put them all together

you have to put your media db secret key and stuff in project settings

where do i get the blocks themselves from?


it’s not there in the new ui. could you send me a screenshot of your media db block and its location? because i dont think we are using the same ui

1 Like

What exactly are you trying to do? Upload a photo from album, take a photo, download an image url, …?

take a photo

basically, im trying to make an app that takes a photo and outputs text. and i supposedly neeb a media db component for that

The camera drawer has the blocks you’ll need:

The “photo from camera” block will allow the user to take a photo with their device. The “url from uploaded file” will take an image and upload it to cloudinary. You can put the first block into the second block.

With most of these blocks, you can right-click and choose “show advanced block” to see more options.

1 Like

you can also add custom secret key and stuff in project settings

thank you sm! i would love it, if you could help me with one more thing, which is OCR. i’m trying to make an app that scans text and puts the output in a list. could you help with that? i’ve tried searching it up, but nothing seems to be working

1 Like

@luv.ak.tech please note that @aishat.yatarovarxr already commented in the original post that you shared.

1 Like

thank you for trying to help, but i’ve already tried that method and it doesn’t seem to be working. do you have any other recommendations?

did you saw the other link from ai2

the second one is for app inventor tho