WebApi GET issue. Not Working

Hey, guys.

Im facing a strange issue with my app. I created an app that talk with a ESP32 via web url. Simple comunnication, but works to me.

My problem is this. The app worked some time ago, but now, it refuses to do what did in the past.


I tried to recreate one simple part in MIT App Inventor, and worked flawlessly.

Somebody faced the same problem?

Thanks in advance.

Your project has six screens. Where is the problem happening? How do we reproduce it?

Thanks for your reply, tatiang.

In the screen CCT (and HUE, RGBW and efeitos), I have some buttons that call an URL like ‘’, in 2700 for example.

The IP is configured in the ‘CONFIG’ screen. I type the IP, press ‘Salvar’ and it gets stored in a variable.

I created a label to show me that the variable is working, and it is.

When I click, it should change something in the ESP32, the way it happened some time ago.

I don’t think it can be reproduced because it works with an ESP32 board that I have here.


I think the WebAPI component does not like when your url does not has https in it and it will refuse to call the api. i tried adding https to my urls and then i see it started talking to the my server. i wonder what the solution for me here?

forgot to mention, my server is a flask app and if i try using ssl_context=“adhoc” and use https://myserverip/ to my server, it refuse to call too, my guess is because the ssl certificate is invalid thats why it prevented itself from running

workaround for this issue is ngrok