[Solved] how can I fix a 403 error using the WEB API

Hello everyone :grinning:
I am working on a geolocation app which uses this api .
And when I run it I get a 403 error which is listed as no HTTPS access in the documentation. Even though my web url starts with HTTP .
And it works fine in the browser as expected.
Is this a thunkable issue? or I have to make changes in my blocks?
these are my blocks :-

Thanks in advance.

1 Like

What is the value of the green error block? It looks like you’re displaying the green status block but we’d need to know what error you’re getting.

It does not give any error as when I put the green error block under if-condition the condition does not take place rather gives the status.

Have you tried set Label11’s Text to [error] in the then do section (not inside the if block)? When you do that, is there a value or is it blank?

by doing that I get the label as undefined

Have you tried it in the companion app? Perhaps is a CORS issue?

Even if your URL starts with HTTP, the Web API will force it to HTTPS. This is I think by design of the Web API component.

1 Like

Is there a way to bypass the issue?

1 Like

See this post

What are browser developer tools?

2 Likes

I tried the test in my iPhone and it works great. but while live testing it in a pc the status is 403. Anyways
solved… thanks @tatiang @muneer :grinning:

2 Likes

That is great. It means that the developers of Thunkable have solved the earlier reported issue even if it wasn’t a complete solution as you have experienced.

Happy Thunking!

3 Likes