Web API Error on Android: Network request failed


I am developing an upp using the Hashify API. I have the following code in my project:

On my iOS device it gives the result as expected:

But on Android I get an error:

Do you have any idea, why I get an error?

There is a similar topic in the community, but I think in my case it is not because of the SSL Certification.

1 Like

What happens when you run the API from the browser of your Android device?

1 Like

Thank you for your answer, it works:

I made a sample project: Thunkable

I hope we can solve it, as it would be very important.

1 Like


I made this change in your bocks

That is interesting. Thank you for your test @muneer! I suppose that you are using Android?

I tested the app on my Samsung Galaxy S8+ and even on BlueStacks (with your changed blocks as well), but I get the same error.

Is it a phone specific error?

1 Like

Yes, I use Android.

Just kill the Thunkable Live App and start it again and it should work.

I just removed the header and tested it and it worked.

I am getting the same error on Android again and again. :disappointed_relieved: :disappointed_relieved:

1 Like

It’s working with me in both Android and Web test.

You can test to generate the APK file and run it from your phone. If it works then you’re OK.

It would help if someone else with Android phone tests it and see if it works.

1 Like

Hi there,

I published my app to the Play Store and a lot of people report me this behaviour, the API and so the function doesn’t work.

Why do I get this error on some Android device?

Well, I think I solved this problem, probably there was a bug on Thunkable, as by deleting the blocks and setting the parameters from the property panel, it does work:


1 Like