Web API crashes app

I’m running this API on my private server. Using this link:

gives me this result:

{“status”:200,“status_message”:“Product Found”,“data”:10}
“10” is the correct data for “pen”.

Trying these blocks crashes my app.

Screenshot from 2020-08-06 09-54-27

Any idea what I’m doing wrong?

Hey @mrtwocanes,

Just tested this on my end on iOS Live Companion. Seeing no issues whatsoever.


When testing this on Web App it crashes. Are you referring to Web Apps specifically? If not, what device are you using?


“eoinparkinson”, thank-you for your reply.

I typically test on a Samsung S6 and a Samsung S9 running the Thunkable Live App. I just tried to test with “Live Test” and then with “Preview as a responsive web app” from the Live Test popup. They both went white and have not changed, so I assume that each crashed. Web App immediately produces a white screen, so no joy there either.

The screen in question works just fine, no crashes UNTIL I put the Web_API1 “Get” block into place.

I don’t have an iOS device, so I can’t test it on that platform.

Well, I fixed it. I’m just not sure how. I created a new project and recreated the code and it started working. I copied the new blocks to my existing project and Bob’s yer uncle, it was working.

Screenshot from 2020-08-06 12-27-52

Knowing the code worked for you, helped me to focus. :joy:

Thanks for your help!!


@mrtwocanes you seem to have 2 variables with similar names.

There’s app apiUrl and app ApiUrl which are (were!) two different variables, this is why you weren’t getting the expected result.