[Solved] Web API Post set Headers not working


I want to use Web Api with Post to set Data on a Web Server. Unfortunately, it is not working when I set Headers and Body via Blocks.
When I set it via Designer it works.
Is there anything which I need to do before? Maybe a special order?

This is working like a charm:

Does not work (I know in screenshot there is a type in Content-Type, but it does not change anything if I write it correctly)

Thank you,

THis is a known issue. I believe the developers are working on a fix for this.

[edit] to clarify. Only the headers need to be set in the design screen. You can definitely set a post body in the blocks. Are you sure your blocks are correct? Do you get an error message from the api you are trying to communicate with

@jared, sry did not see your edit. It is my own api. It works when I use Postman and it also works when I use GET.

I removed the set header block, after that it works.

1 Like

Great work @Kirro ! I will edit the title to indicate solved!