[Solved] OpenAI Undefined as response - But not a credit error

Hello all,
I have got this “undefined” as a response to openai.com API calls. Used to work perfectly.
Checking the console - you can see the errors i have got but they are really like chineese to me. Anyone having an idea…?
Thanks in advance,

Could you please check this? OpenAI ChatGPT API KEY not working - #11 by ioannis

As far as i can see i have still creds and i can use the Playground without disturances…

What happens in your network traffic tab? Do you see the call go out to openAI?

All green as i see it…

What’s that 25 second call? “Poll”


on my side, when i make a completion call, for example, i see sometihng like this

No idea - Did another run. Does it say anthing to you ?

nada. looks like there’s no traffic to openAI.

I agree to that - but it used to work and i tried alot. it all started when the vesion of chatgpt was depreciated and changed to something else.

For my test, I simply created a key and used the blocks as normal. Nothing special.

Have you tried this on a test page with only an open ai call?

I just discovered asmall error - all made by my self… :smiley:
Sorry to bother your time with this. having said this - and very much related is thet i am trying to get a reply (which i do now) but the text is Chopped off when i do the prompt from an Iphone - But NOT when using the Thunkable Live tester

it is also when i try to laborate with the Token “Maximum Length” i do get “undefined” as a reply

when you say chopped off, i’d say ‘why do you think it’s chopped off’

i’d guess your label isnt growing to accommodate all the text.

how are you passing the token maximum length?

The problem is that it does word when irun it on computer screen. But not on phones.
Everything is the same….


happy to test it out on my end

try this

i threw my own code in there.

only thing i could imagine is that you need to replace the blocks because the code was updated on the backend and broke stuff

Dear all
I found the error regarding ”text chopped off”
I did elaborate with the ”max length” of the label to display a massive text block.
In my case iincreased it to 6500 which allowed all text to be shown without any problem.

This case can be closed with solution