[Solved] How do I stop groups from fading when I touch their child components?

I have searched the community and it seems to be a bug.
Do you have a solution?
I realized that in the new editor there are no more rows and columns to organize the screen, so I used groups, but that created a problem:
When I try to click on a control (which I made very small) I can’t because the group is clicked.
How can I solve this problem?
Should I create the screen without groups?
Do the rows and columns no longer exist?


Click on first group

Clik on second group

This is Live Test on Iphone 13

1 Like

When you add components in your screen, you will see the left pane builds a tree like representation of your components.

Make sure the Group component is at a lower order than the components inside it. You can only click on components that are at higher order than the group containing them.

Hope that is clear.

1 Like

I understand what you are saying, but in this way the purpose of the group falls:

  1. have the coordinates of the elements relative to the group reference
  2. move the group around the screen (moving all objects at once)
  3. make the group not visible and make all objects disappear

Cattura

1 Like

I’m not getting you. All what you explained happens when you create the group first then add the components. If you have the components added first then you add a group, you will get this behavior but not all the time.

I have not noticed this with the latest update but this was happening on and off.

Are you sure what you try to click on is part of the group and not placed behind the group?

It does not matter what you create first, if you can place an object within a group, this object becomes a child of the group and therefore its coordinates are relative to the Father’zero and its visibility is related to the Father’s visibility.
Cattura

here’s how I organized the screens

Can you point out the component that does not respond to your click and instead the group is the one responding?


This is true if you want all the objects to be part of the group. In some cases you want an object to be floating above the group in which case it will look like it is part of the group but in reality it isn’t. In this case the floating object should be above the group in the tree.

You are right, I expressed myself wrongly, sorry.
Actually it is not true that the checkbox does not respond to the click, but you have to center it very well otherwise the click is taken by the group.
Since the checkbox is very small, there are more times when the click goes to the group than when it goes to the checkbox.
It would take a group property that says, “not clickable.”

1 Like

the real problem is that all objects are clickable and the ability to click cannot be disabled, which is very confusing to end users.
I understand all the programming difficulties, but this is a paid service, not even very cheap, it should be more reliable.

1 Like

Yes, we need a way to disable the click detection for a group. I posted about this in another topic but we should create a feature request here on the forums and on GitHub.

2 Likes

Honestly it is full of bugs, I regretted choosing this way.

1 Like

What is confusing? i feel like I’m missing something here, sorry.

If it’s clickable, shouldn’t the user be able to click it?

You can hide the group click fading behavior.

the labels, groups and images usually do not have to be selectable, if the user sees that clicking has a fading behavior, he expects him to do a function. how do you get rid of the fading behavior of these elements?

Go to any app with a group

Click the group.

Look at the propert panel, there’s a touch opacity setting :slight_smile:
Play with that to find the optimal setting (try a value of 100)

It’s not a bug, but totally disabling group clicks is a feature request we have on our list! :slight_smile:

It’s likely that the group is so small and when you touch it your finger overlaps to the parent group.

Can you make the area to touch bigger?

2 Likes

yes I enlarged it, but the fader at 100 doesn’t resolve

Are you using the latest version of Thunkable Live @ferrarofcfei?

I thought that 100 worked fine for me - does a higher value (i.e. 1000?) work any better?

2 Likes