[Solved] Error publishing iOS app - issues with incrementing and login info

I am trying to publish (to the Apple App Store) an update for an already published app and received the following twice in a row. Does anyone have any ideas.

I am able to download this directly from Thunkable as an app to my iPhone.

However, when I try to publish to the App Store it does not alone and that is when I receive this error




Command failed: cd /thunkableCompanionTemp/thunkableCompanion_34d971af-9c83-4fcb-92b8-d618b7107fb4/ios && bundle exec fastlane release app_identifier:‘edu.fit.my.jgibb2018’ app_name:“Behavior Report Card” team_id:‘43ZFJ38JGD’ two_factor:‘true’ build_number:‘2020128166’ version_number:‘900’ xcode_project_path:'/Documents/thunkable-for-ios/thunkableCompanionTemp/thunkableCompanion_34d971af-9c83-4fcb-92b8-d618b7107fb4/ios/thunkablecompanion.xcodeproj’ has_push_notification_component:‘true’ profile_uuid:‘2c45571b-541e-47b9-8a4e-97512ca6c1aa’ profile_name:‘Behavior Report Card’ warning: /Users/administrator/Library/Developer/Xcode/Archives/2020-02-28/thunkablecompanion 2020-02-28 16.07.12.xcarchive/BCSymbolMaps/thunkablecompanion-armv7.bcsymbolmap: No such file or directory: not unobfuscating. warning: /Users/administrator/Library/Developer/Xcode/Archives/2020-02-28/thunkablecompanion 2020-02-28 16.07.12.xcarchive/BCSymbolMaps/thunkablecompanion-arm64.bcsymbolmap: No such file or directory: not unobfuscating. /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane_core/lib/fastlane_core/ui/interface.rb:153:in shell_error!': [31m[!] Exit status of command 'xcrun altool --upload-app -t ios -f "thunkablecompanion.ipa" -u [jgibbs@braintrustbh.com](mailto:jgibbs@braintrustbh.com) -p @env:ALTOOL_PASSWORD --output-format xml' was 2 instead of 0. (FastlaneCore::Interface::FastlaneShellError) os-version 10.14.6product-errors code -22014 messageWe are unable to create an authentication session. userInfoNSLocalizedDescription We are unable to create an authentication session.NSLocalizedFailureReason Unable to validate your application. tool-path/Applications/Xcode.app/Contents/SharedFrameworks/ContentDeliveryServices.framework/Versions/A/Frameworks/AppStoreService.framework tool-version 4.00.1181 [0m from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in method_missing’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/helper/sh_helper.rb:80:in sh_control_output' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/helper/sh_helper.rb:12:in sh’ from /Users/administrator/.rvm/gems/ruby-2.6.3/bundler/gems/fastlane-plugin-altool-3d589c4bb9f5/lib/fastlane/plugin/altool/actions/altool_action.rb:39:in run' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:256:in block (2 levels) in execute_action’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/actions/actions_helper.rb:50:in execute_action' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:235:in block in execute_action’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:227:in chdir' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:227:in execute_action’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:157:in trigger_action_by_name' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/fast_file.rb:154:in method_missing’ from Fastfile:380:in al_upload' from Fastfile:287:in block (2 levels) in parsing_binding’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/lane.rb:33:in call' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:49:in block in execute’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:45:in chdir' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/runner.rb:45:in execute’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/lane_manager.rb:56:in cruise_lane' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/command_line_handler.rb:36:in handle’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/commands_generator.rb:108:in block (2 levels) in run' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in call’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in run' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in run_active_command’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:76:in run!' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in run!’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/commands_generator.rb:333:in run' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/commands_generator.rb:41:in start’ from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/fastlane/lib/fastlane/cli_tools_distributor.rb:119:in take_off' from /Users/administrator/.rvm/gems/ruby-2.6.3/gems/fastlane-2.127.1/bin/fastlane:23:in ’ from /Users/administrator/.rvm/gems/ruby-2.6.3/bin/fastlane:23:in load' from /Users/administrator/.rvm/gems/ruby-2.6.3/bin/fastlane:23:in ’ from /Users/administrator/.rvm/gems/ruby-2.6.3/bin/ruby_executable_hooks:24:in eval' from /Users/administrator/.rvm/gems/ruby-2.6.3/bin/ruby_executable_hooks:24:in

Looks like an auth issue @jared

Did you set up a app specific password using the same account as your Apple Developer account?

Also, if that doesn’t work, you could try using a slightly smaller build number??

The app password is not the same at the account password.

I will try everything again. It must be an auth issue because i can direct download the app just fine. I will lower the build number. I’ll try. the last one was 730 :laughing:

I was just thinking you might have a personal Apple account (maybe for iTunes etc) and a professional one for your Apple Developer account. So if you logged into Thunkable with your dev account and generated your app specific password on your personal account that would cause an issue.

Also, 731 should be grand! :joy:

1 Like

In short, i had not incremented. After I did that, I was logging in with an old password. Then I was using the wrong app password.

And I was so sure the first 2 times. Then I checked handwritten notes…

Success! Thanks for the rapid support @domhnallohanlon

I invite everyone to check out my app and provide any critical feedback you have!

1 Like